Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 9 of 9 Posts

·
Registered
2006 chevy trailblazer_ss_1ss
Joined
·
1 Posts
Discussion Starter #1
I have an 06 ss and my headlights wont work, the bulbs are good but only the high beams work, the running lights work as well as the fog lights. I have replaced the bulbs just to make sure and still the same problem, someone please help me!?!
 

·
Banned
2003 gmc envoy_slt
Joined
·
7,190 Posts
Switch relays #45 and #46. See if that works.

If they work now you need a new relay.

About $40 at auto parts stores. Cheaper, I think, at Rockauto, if you can wait.
 

·
Banned
2007 chevy
Joined
·
4,644 Posts
Switch relays #45 and #46. See if that works.

If they work now you need a new relay.

About $40 at auto parts stores. Cheaper, I think, at Rockauto, if you can wait.
:iagree:

That or check junkyards around you to see if there's any TrailVoys. When mine went out, I went to a junkyard and got 2 relays off a totaled Envoy for $5 IIRC.
 

·
Registered
2004 isuzu ascender
Joined
·
2 Posts
Switch relays #45 and #46. See if that works.

If they work now you need a new relay.

About $40 at auto parts stores. Cheaper, I think, at Rockauto, if you can wait.
I have an 04 Ascender that was doing the same thing - dim lights went out, but bulbs were still good. I checked the wire connection at the bulb, and both were burned and melted. I replaced both connections, and they work great now. Good Luck.
 

·
Registered
2004 isuzu ascender
Joined
·
2 Posts
Headlights won't work

Switch relays #45 and #46. See if that works.

If they work now you need a new relay.

About $40 at auto parts stores. Cheaper, I think, at Rockauto, if you can wait.
I have an 04 Ascender that was doing the same thing - dim lights went out, but bulbs were still good. I checked the wire connection at the bulb, and both were burned and melted. I replaced both connections, and they work great now. Good Luck.
 

·
Banned
2003 gmc envoy_slt
Joined
·
7,190 Posts
I have an 04 Ascender that was doing the same thing - dim lights went out, but bulbs were still good. I checked the wire connection at the bulb, and both were burned and melted. I replaced both connections, and they work great now. Good Luck.

That happens a lot too, but switching the relays first, is easier.
 

·
Registered
2005 gmc envoy_slt_xuv
Joined
·
3 Posts
Switch relays #45 and #46. See if that works.

If they work now you need a new relay.

About $40 at auto parts stores. Cheaper, I think, at Rockauto, if you can wait.
It’s an old thread but it did the trick for me.
Thanks WOOLUF1952!!!!

Oh and make sure you open the box before leaving the parts store, apparently looking up the right parts is a dieing art.

Bill
 

·
Registered
2004 GMC Envoy SLT 4.2
Joined
·
289 Posts
It’s an old thread but it did the trick for me.
Thanks WOOLUF1952!!!!

Oh and make sure you open the box before leaving the parts store, apparently looking up the right parts is a dieing art.

Bill
Pretty sure that has to do with you knowing more than the minimum wage employee doing the 'looking' . :(
And , good you got the problem taken care of . ?
 
1 - 9 of 9 Posts
Top