Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

81 - 86 of 86 Posts

·
Registered
2004 chevy trailblazer_ls
Joined
·
1 Posts
Low Beam Headlights no-go

Sorry you had the problem.... BUT I just had it this morning (17 April2014)
Thanks to all - I repeated your instructions and my HDM relay #46 is bad too... Headed to Chevy dealer - thanks again
 

·
Registered
Joined
·
1 Posts
I have a 07 trailblazer and the low beams wouldn't turn on, I temporarily swapped the 45 and 46 module around and I had lights. Thanks TBLAZED
 

·
Registered
2004 chevy trailblazer_ls_ext
Joined
·
3 Posts
Left side low beam is inop

My 04 Trailblazer driver side low beam does not work. I replaced the bulb and no change. I checked the socket and found it was bad. I just replaced the socket and no change. The new socket has power at both leads but the bulb will not come on. I had another new bulb on hand so I tried that, no luck. Anyone else run in to this??? I checked the fuses and they are ok too. I am at a loss.
 

·
Registered
2004 chevy trailblazer_ls_ext
Joined
·
3 Posts
2004 Trailblazer Left side Low Beam inop part 2

I just replaced the entire headlight assembly thinking starting off with a clean harness and all. No change. Left side low beam still not working. Fuse is fine and has been checked with a tester.
 

·
Registered
2004 chevy trailblazer_ls_ext
Joined
·
3 Posts
Left Low Beam issue Fixed

Ok, I metered out the aftermarket light. bad ground. So I will be making a new ground wire.
 

·
Registered
2003 gmc envoy_sle
Joined
·
42 Posts
Me too! Haven't actually checked yet but from all of the questions about it, it has to be it.:woot::hail::woot:
 
81 - 86 of 86 Posts
Top