Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
hey guys. First off I am new to the site, and appreciate all of the info you give to everyone here!!! I have an 06' trailblazer and have 2k miles left on the warranty. Two months ago, something electrical went, sorry for being vague, i don't know much about cars... I was only able to drive it at 35mph and went straight to chevy. They said my radio was sending an electrical charge and blowing the main fuses in the engine compartment.
A few weeks ago i noticed my rear wiper stopped working and when i opened the tailgate, it started making a loud "clicking" noise like it was unlocking... I brought it to chevy again, and they said the noise was caused by an aftermarket keyless entry system that was installed by another chevy dealership that went out of business. They changed the motor for the wiper and said they pulled the fuses for the keyless entry system because chevy wouldn't cover it. The next day i noticed the wiper stopped working, the noise was still there, and the keyless entry still worked...
I was going to make an appt to bring it back, when while i was driving, i lost all power. The only lights that were on, were the warning lights on the dash. I lost everything and was able to veer off the road to a stop. The truck wouldn't restart and i was towed to a different chevy dealership. They have had the truck for 2 days and want me to pick it up tomorrow, stating the only thing they found wrong was a dead battery... Needless to say they aren't covering the rental car, and i am paying for the battery... Does this make sense and seem like a logical issue that could be caused by the battery? Like I said, I don't know anything about cars, but this doesn't seem right... I only have 2k miles left on the warranty and feel like i am being strung along until the warranty is up... Any help with this would be GREATLY appreciated! Thanks again for all you guys do on here.
Patrick
 

·
Registered
2004 chevy trailblazer_ls
Joined
·
1,191 Posts
1st off

Welcome to the site !!

Hmmm... im not to sure on your situation but ill try shed some light where i can. i know others will chime in soon.

The lock thing you hear in the back, is it when u close the liftgate ?
if so, thats completely normal.

I wouldnt be surprised if the problems were caused by the battery.
Mine was weak and all kinds of wacky things started happening to my electrical things. Also these cars have an electronic throttle so maybe the reason it went to reduced power was because it didnt want it to die?? Im not really sure though,just sptiballin ideas out here.

hope this helps a little bit
 

·
Registered
2004 chevy trailblazer_ls
Joined
·
694 Posts
Welcome!

This sounds exactly like what happened to my 04 Colorado. Luckily I know the owner of the dealership and he told the service manager to find the cause and fix it under warranty, even though I was 2k over. It turned out it had a bad fuse box and it was causing all kinds of stuff like that to happen untill it did the exact same thing and wouldnt start and had to be towed to the dealership. :m2:

To elaborate on what happened with mine... the windows went down on there own, the radio went off and on by itself, the wipers would stop working in the rain, the battery died 3 times in the coarse of 2 months, and the tail lights completely stopped working.

PS: please fill out your user profile
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
Thank you sooo much for that info! To specify with the first reply, the noise happens while the tailgate is open and stuff is being loaded into the back... I will definitely fill out the profile, and speak to the dealership today when i pick up the vehicle... Thanks again!!!
Pat
 

·
Registered
2002 gmc envoy_sle
Joined
·
1,531 Posts
Well the comment about the battery being dead is the only problem they found sounds funny to me. Once your car is running you don't need a battery because your alternator is supplying power. I would check to make sure your alternator is working properly.
 

·
Registered
2004 chevy trailblazer_ls
Joined
·
694 Posts
Well the comment about the battery being dead is the only problem they found sounds funny to me. Once your car is running you don't need a battery because your alternator is supplying power. I would check to make sure your alternator is working properly.
:iagree: That is probably something they just made up cause they didn't look for the problem to hard and to get you out the door. I doubt there is something wrong with your alternator, but it is a possibility. That wouldn't cause all the problems you are describing.
 

·
Registered
2002 gmc envoy_sle
Joined
·
1,531 Posts
:iagree: That is probably something they just made up cause they didn't look for the problem to hard and to get you out the door. I doubt there is something wrong with your alternator, but it is a possibility. That wouldn't cause all the problems you are describing.
a bad alternator would cause his main problem which was losing all power and then not being able to restart the engine. If the alternator failed then the car was running on battery only, after awhile it will drain the battery enough to where the computer will die and kill the engine
 

·
Registered
2004 chevy trailblazer_ls
Joined
·
694 Posts
a bad alternator would cause his main problem which was losing all power and then not being able to restart the engine. If the alternator failed then the car was running on battery only, after awhile it will drain the battery enough to where the computer will die and kill the engine
And while I agree with this, it wouldnt cause his rear locks to lock and unlock on their own, or the windshield wiper motor to fail, or all the dash warning lights to come on at the SAME time. It may have caused the reduced engine power though.
 
1 - 8 of 8 Posts
Top