Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 2 of 2 Posts

·
Registered
2006 gmc envoy_denali
Joined
·
2 Posts
Discussion Starter #1
I have read just about every thread about this issue. I have already completely rebuilt the front suspension and front brakes on 2006 GMC Envoy Denali (new upper & lower control arms, new upper and lower ball joints, new CV shafts , new sway bar bushings, new sway bar end links, new brake calipers, brake lines, rotors, and front hub assemblies), but still there is the rattle when driving. It does not always happen when just hitting a bump, just driving down a normal road. This vehicle has selectable 4WD and the actuator and axle disconnect is working. The rattle appears to be from the drivers side front, where the strut mounts are. There are two new struts, I even switched the struts from one side to the other, the rattle is still there. Can this be coming from the differential. If I engage 4WD, with both front tires off the ground, and get under and move on tire, there is a good amount of free-play or slop in the differential gears. But when on the road and 4WD engaged there is no noise or indication of a problem. Help!
 

·
Registered
2003 gmc envoy_slt
Joined
·
56 Posts
front sway bar end links?

i did the same front end rebuild work, and had a similar noise. found out that the sway bar end links were not tightened up enough, which caused a mysterious knocking sound at low speed. once the end link nuts were torqued down, no more noises.
 
1 - 2 of 2 Posts
Top