Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 5 of 5 Posts

·
Registered
2006 chevy trailblazer_ls
Joined
·
4 Posts
Discussion Starter #1
Howdy.

I have a 2006 TB 4.2 liter. 172k miles.

I have been fighting the P0171 code for a few months now. It showed up when the weather started to get cold. There has been no notable difference in how the car runs when throwing the code, idles great at 600 RPM, runs fine, no problems except the light on my dash.

I have cleaned the MAF, cleaned the throttle body, ran every kind of fuel additive/cleaner through it. Air filter is a K&N. Air intake temp sensor seems to be functioning normally. I have an UltraGauge and use that to monitor the vehicle and clear the code. P0171 is the only code that pops up.

About three years ago the TB started running really rough and almost always dying when idling in cold weather. Put a new O2 sensor in it and that fixed it. So I am pretty sure I isn't an O2 sensor now.

If anyone can help me diagnose the issue here, that would be great. I plan to sell this rig soon when I buy a new truck. Not trying to pass any problems to the next guy, that car runs and drives like it did when I bought it 10 years and 120k miles ago. Just this stupid code sets off the CEL daily.
 

·
Registered
2006 chevy trailblazer_lt
Joined
·
76 Posts
This is a heavy discussed topic for the Trailblazer, Envoy and Bravada, as it is a common problem with the 4.2L I6 engine. Plain and simple, the minimums to change out are the intake manifold gasket (make certain all mating surfaces are clean) and change out the PCV breather hose. The minimums to do after those repairs, clean out the PCV port on top of the valve cover with a pipe cleaner and a minimal amount of carburetor cleaner, change out the dry rotted or missing cap on the front, passenger's side of the intake manifold vacuum port.

Change out if your vehicle has one or both of the following:

1. Dry rotted or missing vacuum hose that runs from the passenger's side of the intake manifold vacuum port to the air box that sits on over top of the pistons.
2. Replace the Secondary A. I. R. Injection Valve

I have an '06 Trailblazer as well and had to replace everything I've just stated, in order to get the Trouble Code P0171 to fully clear out. Good luck in your repairs! (y)
 

·
Registered
2006 chevy trailblazer_ls
Joined
·
4 Posts
Discussion Starter #3
Is the PCV breather hose and the hose that connects the top air box to the intake manifold on the front top passenger side of the motor the same thing? I’ve noticed mine seems to be lifting off from the nipple and has a ton of black sludge and crud around the nipple. I wipe it away and it keeps coming back. I’ve ordered a new hose and will change it out and see.
 

·
Registered
2006 chevy trailblazer_lt
Joined
·
76 Posts
"Is the PCV breather hose and the hose that connects the top air box to the intake manifold on the front top passenger side of the motor the same thing?" This question makes no sense... I will correct what you mean.

On your engine, there may be a vacuum hose that runs from the front, passenger's side of the intake manifold on the driver's side of the engine to the driver's side of the air box that sits over top of the spark plugs. This vacuum hose is 'not' on every 4.2L I6 engine, however. On your engine, there may be a vacuum hose that runs from the K & N air filter housing to a Secondary A. I. R. Injection Valve. The Secondary A. I. R. Injection Valve sits on the passenger's side of the head of the engine. However, not every 4.2L I6 engine has the Secondary A. I. R. Injection Valve. Only you can determine if you have the optional hoses, unless you post pictures of your engine, so the rest of us can point out what vacuum hoses you have. The PCV hose is on 'every' vehicle, however.

The reason why your PCV hose keeps lifting off the valve cover nipple is because the hose is dry-rotted and expanded to the point that a tight seal is no longer possible. Replacing the PCV hose is the only thing that can solve the issue of the old hose popping off the valve cover nipple. The reason why you have "a ton" of black sludge is because of a lack of routine maintenance. Sure, the black, liquidy sludge is normal to see. But, "a ton" is indicative of a lack of maintenance.

The maintenance you're going to have to do is, take 'all' of the air intake system off and clean the entire interior of all pieces, including the nipple on the air box that the PCV hose connects to. Next, you're going to have to clean out the valve cover nipple with carburetor cleaner by using cotton swabs and/or pipe cleaners. Then, wash, dry and re-oil the K & N air filter. Make sure you do these three on the same day, not one on one day and the others on a different day.
 

·
Registered
Joined
·
25 Posts
I had 2 coil packs going bad and it kept throwing weird codes until it finally detected the misfire. You can test the coil packs via YouTube and a multimeter
 
1 - 5 of 5 Posts
Top