Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 7 of 7 Posts

·
Registered
2005 chevy trailblazer_lt
Joined
·
46 Posts
Discussion Starter #1
Have anyone ever heard of any problems with the store bought upgraded resistor/module packs for 05 TB/Envoy? I see the plug has to be spliced in to the old harness. Wondering if these control heads recognize these newer parts rahter than the oe direct fit style. The upgraded module is made by EEC Standard and 129.00 at napa or carquest stores. However I see them at gm direct for 59.00 but looks like the old style part. I replaced the module and fan still is not working. My next target is the hvac control panel being replaced. BTW I put in a different module to rule out a defective new one. Head units are $$$...all venting/ac/defrost etc work except fan. I installed the old resistor that kinda worked before being removed and now it does nothing. I want to make sure that the head unit on dash does not have a problem with aftermarket parts instead of the delco fan module. My head/dash unit model # is 15220319, checked plug and were secure. Advice please....thank you
 

·
Registered
2009 chevy
Joined
·
6,431 Posts
It sounds, to me, like you installed the wrong blower speed control module.

First of all, the replacement module does not need to be spliced into the existing wiring harness; yes, you can buy a new module along with a new connector, and, the new connector needs to be spliced into the old harness.

These are two separate parts, with two separate prices. Maybe you bought both (without realizing) and spliced them into the old harness.

If that is what happened, perhaps the wiring needs to be rechecked.

From your description, the problem is either the resistor module (and/or the connector), or the blower motor.

I do not think the problem is in the dash unit.
 

·
Registered
2005 chevy trailblazer_lt
Joined
·
46 Posts
Discussion Starter #4
I did check the blower,the blower is good, 12v put to it and spins before i even started this project. the module i bought has all five wires comming out of one harness, two for the fan(same colors) and 3 for the power, ground and signal from head unit. Not defending it but it's and improved part over the mis-design which causes people all this grief. I am going to buy the delco module to install before i attempt the control head unit. I was just curious if anyone has ever used and non-delco part and had success with them. The newer design has 5 heat sink blades rather than the two that is typically pictured on the net sites. I found it odd having to splice in the wires but from what i have read others have done it with success. It just maybee my year and head unit thats not jiving with it. Anyway thanx for the replys folks.......:bonk::grouphug::bonk:
 

·
Registered
2005 chevy trailblazer_lt
Joined
·
46 Posts
Discussion Starter #5
BTW, this site has the same module that is being sold as redesinged that the poster had purchased......http://forums.trailvoy.com/showthread.php?t=89382 at the end of the post is the diagram and the same exact part that I have. was installed correctly too...put two of them in...just one question..12v put to blower and spins fast...does this eliminate lower controlled speeds that pur 12v wont produce? this is why i'm leaning towards head unit
 

·
Registered
2009 chevy
Joined
·
6,431 Posts
Ok, in post #5, you provide a link to a TrailVoy thread; that thread is talking about the speed control module for the automatic HVAC units.

In post #1, you provide the part number of your HVAC dash unit; that part number, is for a manual control unit.

These two parts will not work together.

As I suggested, in post #2, you may be trying to install the wrong speed control module.
 

·
Registered
2005 chevy trailblazer_lt
Joined
·
46 Posts
Discussion Starter #7
problem solved, the fan module IS correct and the head hvac control unit is tested out fine. lesson to all, check ALL fuses, I missed the "j" fuse under the hood which was blown...3 buck fix...fyi dont goto napa, carquest for the fan modules. I looked at the Delco replacement that is an ugrade AND DOES REQUIRE SPLICING and theya re the same part and delco was half the cost. thanx for all the help and replies
 
1 - 7 of 7 Posts
Top