Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 3 of 3 Posts

· Registered
2002 chevy trailblazer_ls
Joined
·
23 Posts
Discussion Starter · #1 ·
So I was haveing problems with my thermostat (it was sticking open) so with nearly 100K in on the clock I figured I would use the long 4th of July weekend and replace the waterpump, fan clutch and the thermostat while it was all apart. The install went smoothly and everything was running great until a few days ago...
The SES light came on and the code was p1481 (no signal from fan clutch)...well F$%&...So I decided to tear it all down again and try and find the problem 1 more time before I took it in to the Chevy house.

Today I took it all apart this morning and there was the problem...the wiring harness from the new fan clutch came unhooked from the new clutch :weird:

So to fix the problem I took the wiring harness from the original clutch and installed it on the new part. after the reinstall everything works like a charm.

I was looking at what might hacve caused the original harness to come unhooked and found that the new harness was much lower quality than my original harness i.e. no weather seal like the original, clip was much weaker that the original and connection was not as firm as the original...

Moral of this story is I feel that I should have spent a little more money to get a OEM part instead of trying to save a few buck and purchased a lower qualty product. :thumbsup:
 

· Premium Member
2007 chevy trailblazer_ls
Joined
·
1,456 Posts
What brand did you purchase?
 

· Registered
2002 chevy trailblazer_ls
Joined
·
23 Posts
Discussion Starter · #3 ·
Dorman...

I thought they were supposed to be a good brand or maybe it was just a one off kind of fluke deal. :undecided
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top