Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 8 of 8 Posts

·
Registered
gmc envoy_sle
Joined
·
19 Posts
Discussion Starter #1
2002 Trailblazer, bad vibration at idle, removed serpentine belt, most went away, with belt back on,it can be felt in the fan shroud. I was wondering if anyone has had this problem, planning on replacing clutch, and fan, planning on removing clutch assy and see if vibration goes away before I completely disassemble...just unscrew and secure it out of the way.

Bill
 

·
Registered
gmc envoy_sle
Joined
·
19 Posts
Discussion Starter #3
Probably Water pump, unscrewed fan and laid it out of the way, started engine, vibrate not as bad but, still some there, pulled slack in serpentine belt, was able to move pump assy some, gonna replace pump, and clutch. I'll post if that don't fix it.

Thanks for the input...Bill
 

·
Registered
gmc envoy_sle
Joined
·
19 Posts
Discussion Starter #4
Fan clutch

Replaced fan clutch, and water pump, very little, if any difference.
Just going to drive it til something starts to make noise, then start over.

Bill:duh:
 

·
Registered
gmc envoy_sle
Joined
·
19 Posts
Discussion Starter #6
99% sure,it's the fan. With the belt off smooth as silk, been swapping clutches, and blades, finally traced it to the blade, put new blade on ...it wobbles and vibrates so bad, can't hardly stand to drive it. Working on it later today, I'll post when I get it going.

Bill
 

·
Registered
2006 chevy trailblazer_lt_ext
Joined
·
27 Posts
clutch fan

had a vibration from engine---- 4.3 chevy blazer--- removed belt vibration stopped. replaced clutch fan assy. runs smooth. new fan and clutch fixed it for me good luck:)
 

·
Registered
gmc envoy_sle
Joined
·
19 Posts
Discussion Starter #8
Da FAN....replaced with new fan, worse than ever...Replaced with Upullit fan, much better, it's bearable for now.

Thanks for all the input...Bill

P,S. I've got it down to a 30 minute job now that I know what tools are needed.:woohoo:
 
1 - 8 of 8 Posts
Top