Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I have changed the fan clutch on my 02 Bravada. 1st startup after the change produced P1481 and P1482. After checking around I found the cooling fan fuse (20) was blown. Changed that and the fuse blew again as soon as the ignition was switched on.
I had replaced the fan clutch with a non-GM one. the wiring from the new fan clutch has the same number of wires but different colors. Red, black, blue, brown and yellow instead of the original gray, blue, gray/white, white and black.
Anyone have any suggestions as to what I can do to fix this?
Thanks
 

·
Premium Member
2003 chevy trailblazer_ls
Joined
·
481 Posts
P1481 is for a Loss of Cooling Fan Speed Signal and P1482 is for incorrect voltage. First thing I would try is disconnecting and reconnecting the wiring for the fan clutch. Also, what is the brand and part number of the clutch you installed?
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
I got it from the internet, US Autoparts Network Inc. PN 6313601 Envoy 02-06 Fan Clutch.

I have unplugged it several times, checked to make sure the pins were not bent and seating correctly. I still have the old clutch and harness. I was thinking about replacing the harness with the old one.
 

·
Premium Member
2003 chevy trailblazer_ls
Joined
·
481 Posts
Replace the fuse with one that is rated 5 amps higher and see what happens.
 
1 - 7 of 7 Posts
Top