Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 6 of 6 Posts

·
Registered
2004 chevy trailblazer_ss_lt
Joined
·
6 Posts
Discussion Starter #1
hello all new to the forums today! i need your guys help today i changed my air filter, fuel filter oil, filter, spark plugs. and cleaned my throttle body i took it off and moved the plate a lot i held it open with my finger and cleaned all inside now i know that that is bad. i buttoned the car back up and went to take it for a test drive i started it up and the truck was shaking and the reduced power and service engine soon light came on. i do not have a scanner. i cant even pull out of my drive way with out it stalling out on me it does not even want to restart i have to really try. CAN SOME ONE PLEASE HELP ME! :thx
 

·
Registered
2006 saab 9_7x
Joined
·
450 Posts
Was the battery disconnected while you cleaned the TB? If not, try this, disconnect the battery for at least 30 minutes to allow the PCM to reset to default settings. What spark plugs did you use?
 

·
Registered
2004 chevy trailblazer_ss_lt
Joined
·
6 Posts
Discussion Starter #3
I didn't see the post so i pulled the fuses for the PCM and let them sit for about 1 hour and then put them in the car runs better but still messed up. im using bosh plugs. i started it and heard rattling in one of the cylinders i looked at my old spark plugs and notice a chip in one i think the porcelain fell in im going to try to suck it out with a shop vac and a piece of tubing:duh::duh::duh:
 

·
Registered
2006 saab 9_7x
Joined
·
450 Posts
Most members point out that the AC Delco 41-103 are the plugs to use. I don't think that the Bosch plugs are the cause of the symptoms you're having, just that other plugs don't seem to do well in the 4.2 Are all the coils seated properly? Did you pull any codes?
 

·
Registered
2004 chevy trailblazer_ss_lt
Joined
·
6 Posts
Discussion Starter #5
they are all seated right. I think theirs porcelain in the engine i have to try and suck it out with a shop vac and tubing
 

·
Registered
2004 chevy trailblazer_ss_lt
Joined
·
6 Posts
Discussion Starter #6
I got it all out and put the whole car back together now. my engine knocks and shakes all the cylinders seem to be firing. its like it is running normally but shakes and knocks like a savage
 
1 - 6 of 6 Posts
Top