Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 2 of 2 Posts

·
Registered
2004 gmc envoy_slt_xuv
Joined
·
4 Posts
Discussion Starter #1
My 2001 5.3 has a weird problem at cold starts when the truck hasn’t been driven for a couple days or more. The longer it sits the worse the first cold start is. It starts up immediately but is really harsh for a split second before normal idle. My guess was that one of the injectors is leaking fuel into the cylinder super slowly thus the super quick surge/high rev at cold start. Zero misfire or dtc codes with the exception of a B1000 code that may be a bad ground but I didn’t think it would be related.
i found a tiny crack in the rubber elbow that attaches at the side port nipple on the fuel pressure regulator but wasn’t confident that a vacuum leak would be the culprit since it’s only a cold start problem and only after sitting for more than a day. If I park the truck and then drive it the next morning the harsh start doesn’t happen. During the day I can turn it on and off and never replicate the issue. I’ve got 170k on odometer and new spark plugs and wires.
any help would be greatly appreciated. I’d change out all the injectors but that seems like a waste at $80 a pop.
 

·
Registered
Joined
·
9 Posts
I am not mancanicly inclined but it could be a air temperature sensor but I am not 100% sure. I had a air temperature sensor out on a different car it was not wanting to start up when it was cold I hope the helps.
 
1 - 2 of 2 Posts
Top