Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 20 of 28 Posts

·
Registered
2004 chevy trailblazer_ls
Joined
·
12 Posts
Discussion Starter · #1 ·
Yesterday was a fun day for me. We went out of town to see my aunt who was in the hospital. Pull into the parking garage and see engine temp go through the roof and steam come from under the hood. Come to find out it was a heater core line. And...nobody had it in stock. We bypassed the original line and put in a rubber heater core line, and it is working good. One small problem, when we turn the heat on while at idle, the engine would die. At least we were able to get home(hospital was more than an hour away.) This morning we get out to look it over some more and after fiddling around, when we turn on the heat, it does not kill the engine any more. Now it only dies at idle when I turn on the AC. At highway speed when I turn the heat on, engine stalls out a little bit but does not die. Any ideas? Thanks for looking!
 

·
Registered
2003 chevy trailblazer_lt
Joined
·
6,568 Posts
first thing i would do is clean the throttle body... there is a how-to in the article section... 95% of the time its just that...
 

·
Registered
2003 chevy trailblazer_ls
Joined
·
5,268 Posts
during your work on the heater hose... did you disconnect battery for 30 min or more?

Usually the battery disconnect AND a dirty throttle body will display those symptoms.

Follow that how to.....
 

·
Registered
Joined
·
5,024 Posts
I guarantee its the throttle body.....you'll see how dirty it is once you take it apart.....good luck!!
 

·
Registered
2004 chevy trailblazer_ls
Joined
·
12 Posts
Discussion Starter · #6 ·
Thanks for the help!

Thanks for the help everyone! TB runs great now. I was really surprised how dirty that was and how much of a difference it made to clean it. Now I have to get that muffler on!:thx
 

·
Registered
2004 chevy trailblazer_ls
Joined
·
2 Posts
looking for advice

hello out there i'm afj71. New to the community and found what i was looking for THANK YOU for the help with my ride and i hope i can be of service as well. my problem is: my trailblazer (04) dies when i turn on the heater or ac so i will try and clean my tb and see how it does. Thanks again
 

·
Banned
2003 gmc envoy_slt
Joined
·
7,190 Posts
:tiphat Welcome :tiphat . The cleaning should fix your problem.
 

·
Registered
2004 chevy trailblazer_ls
Joined
·
2 Posts
A huge THANK YOU

Just wanted to say that cleaning my tb did the trick. It was very dirty and after all the cleaning and putting it back together it works great, you guys are totally awsome. If I could i would buy you a cold one and say thank you you really helped me out. Have a great holiday weekend and thanks again :thx
 

·
Registered
2004 chevy trailblazer_lt_ext
Joined
·
16 Posts
TB dies when ac is turned on

How does cleaning the throttle body have anything to do with the ac? My TB died today and I replaced the battery and it started running like crap, finally it leveled out and is running fine until I turn the ac on then it almost dies unless I hold the throttle to it. Does anyone think that my problem could be solved by cleaning the tb? Also HELLO everyone I am new here and so far this forum looks great and it seems there is alot of great info here!!
 

·
Registered
2002 olds bravada
Joined
·
2,369 Posts
Your problem is definitely a dirty throttle body. It always is. When you disconnect the battery, the PCM resets and thinks the throttle body is clean when in reality it isn't. Because its "drive-by-wire" or electronic, its much more sensitive and doesn't actually let in the air that the engine needs due to the gunk on the other side. Explanation isn't that great, but its the solution. Take it off and clean it. I will guarantee it will fix your problem.
 

·
Registered
2005 chevy trailblazer_ls_ext
Joined
·
330 Posts
It never hurts to try. This is something that cant make it worse and has worked for others so why not? And welcome to the site while I am at it:)
 

·
Registered
2005 chevy trailblazer_ls_ext
Joined
·
330 Posts
Just wanted to say that cleaning my tb did the trick. It was very dirty and after all the cleaning and putting it back together it works great, you guys are totally awsome. If I could i would buy you a cold one and say thank you you really helped me out. Have a great holiday weekend and thanks again :thx
I'll take a cold one. You can tap those rockies and mail one to every member if you want;)
 

·
Registered
2004 chevy trailblazer_lt_ext
Joined
·
16 Posts
Thank you very much. I will try it first thing in the morning. Now that you explained it, it really does make sense. I will let everyone know if it works or not. By the way do any of you know anything about 4 wheelers? I know this is a TB forum but the issues that I am having I cannot find on the atv sites.
 

·
Registered
2005 chevy trailblazer_ls_ext
Joined
·
330 Posts
You can post about whatever you want in the general topic forum.. non-related to trailvoy is fine as long as its in the correct forum
 

·
Registered
2003 chevy trailblazer_ls
Joined
·
107 Posts
It could also be this..

My TB was running kind of off, it wouldn't idle all that great and it would stall occasionally so i thought it's the throttle body again. I take it apart and it doesn't look too bad because I cleaned it 45,000 miles ago. I give it a quick spray and wipe down and it seem to be back to normal with the normal battery reset and all. Nope back to it's old habits of weak and varying idle, stumble at take off but fuel economy was still good and no codes. I thought eventually it is going to throw a code, well it did and it was the t-stat and like a frog in a pan of water it had been getting worse but I didn't click it was a stat. Anyway at a 163,000 miles the original stat was failing so I put a new one in and it runs great!
 

·
Registered
2004 chevy trailblazer_lt_ext
Joined
·
16 Posts
I am going to go clean the throttle body in a few mins so I will reply with the results soon. If any of you know anything about atvs please send me an email.
Thanks!!
 

·
Registered
2004 chevy trailblazer_lt_ext
Joined
·
16 Posts
car dies when ac is turned on

All I have to say is thank you very much wardak33!!! That fixed the issue instantly. Also even if this does not happen to anyone else it is a good idea to take the throttle body off and clean it anyway, that thing was so nasty. It had about a 1/16 worth of gunk build up on it. Now its clean as a whistle and running smooth. Now if some one could tell my why atv wont start and spits fire out the carb that would be great!! If this is the wrong forum let me know. Thanks everyone!!
 
1 - 20 of 28 Posts
Top