Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 10 of 10 Posts

·
Registered
2002 chevy trailblazer_lt
Joined
·
41 Posts
Discussion Starter #1
when i am in park and rev my engine when its winding down the rpms it almost goes to 0 goes very low sometimes it stalls just when i rev my engine in park\
it like rumbles and almost stalls any suggestions?
 

·
Registered
2009
Joined
·
1,088 Posts
If you haven't already I would start with cleaning the throttle body. You can do a search for how to do it. Seems to be about a thirty minute job.
 

·
International Chapter
2004 chevy trailblazer_ls
Joined
·
3,900 Posts
Yup, classic TB issue:yes: start cleaning :D real easy job with basic tools, you'll find a how too some where here, have a nice one :)
 

·
Registered
2002 chevy trailblazer_lt
Joined
·
41 Posts
Discussion Starter #4
thanx anything else u suggest...? i was thinking my system was robbing my power so i bought a optima yellow top but it didnt really make a difference i got about 1700watts in my trunk.
 

·
Registered
2002 chevy trailblazer_lt
Joined
·
41 Posts
Discussion Starter #6
does it when im idle at red lights when i roll up my widnows or use sumtin eletric like the a/c kicking on makes my car rumble .. low rpm
 

·
Registered
2004 chevy trailblazer_lt
Joined
·
128 Posts
definitely not your stereo with only 1700 watts... i have about 7000 watts and stock alternator is fine with upgraded wires and two batteries... these tblazers have pretty good charging systems...and 1700 watts isnt anything to worry about... i'd be its the Tb issue... does it run fine other than that? or does it seem to have a miss while driving??? hows the fuel consumption?
 

·
Registered
2002 chevy trailblazer_lt
Joined
·
41 Posts
Discussion Starter #8
i dunno about misfire while driving if im a lil hard on da peddle the gears get a lil hard but it def misfires cause of low idle when im at lights cause of eletronics windows a/c but only sumtimes my fuel cosumtion is horrible i think i get like 220 miles per tank if im lucky and its a 17g tank im pretty sure and i just bought a knn airfilter a few months ago and i dont think its that dirty but i dont know if the spark plugs have ever been changed l ihave 90k miles i bought it used at 69k i have a powertrian warrenty till 110k or 3yrs its been almost 2
 

·
Registered
2003 trailblazer_lt
Joined
·
9,856 Posts

·
Registered
2002 olds bravada
Joined
·
2,369 Posts
X5 on the throttle body issue. clean it and see if it makes a difference. and don't forget to disconnect the battery for 30+ minutes to clear the PCM.

and chances are spark plugs haven't been replaced on your truck. you're close to that 100k mile mark, so i would do the now and get it done and over with. ACDelco Iridiums seem to work the best for our engines (assuming you have the 4.2 i6). they cost around $7-8 a plug, but should last you another 100k miles, and noticeable improvements.
 
1 - 10 of 10 Posts
Top