Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 3 of 3 Posts

·
Registered
2002 chevy trailblazer_ltz
Joined
·
23 Posts
Discussion Starter #1
I have had my 02 LTZ for a couple of months and like driving this more every day. I do have some problems , When I first brought this from a friend, who took great care of the truck, the speedometer registered 30 MPH when standing still and added 30MHP to what ever speed I was driving . It did this for about 10 miles and has never done this again. I also get the ABS and brake light to come on about 20% of time. Then yesterday the Air bag light came on for the passenger seat. It has not came on again. Any clues as to what is going on.
I talked to my friend and they did not have any problems like this, they bought it new. I have 70,000 miles on the truck. Everything else works great.
 

·
Banned
2003 gmc envoy_slt
Joined
·
7,190 Posts
The only things that come to mind are an old battery and/or bad ignition switch.
 

·
Registered
2003 trailblazer_lt
Joined
·
9,856 Posts
...the speedometer registered 30 MPH when standing still and added 30MHP to what ever speed I was driving.
Sounds like a possible speedo stepper motor crapping out. Run a search, there are plenty of threads on them.

I also get the ABS and brake light to come on about 20% of time.
Can't say what's wrong until you get the code(s) read from the EBCM.

Then yesterday the Air bag light came on for the passenger seat.
I would get the code(s) read from the ACM.
 
1 - 3 of 3 Posts
Top