Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 13 of 13 Posts

·
Registered
2004 gmc envoy_slt_xl
Joined
·
14 Posts
Discussion Starter #1
Please Help ...

I got a 2004 envoy XL I've change about 5 to 6 drive shaft seal on different vehicles but i'm stuck on my voy.... :hopeless

Been hammering with brass tip but drive shaft will not move... Is there a special lock or something that i don't know about??? Only lock i know is a C clip at end of shaft...

I've read a few of the threads on the site and i was looking into buying a CV Joint puller if it works...

any suggestions would be appreciated ...:)

Thanks in advance...
 

·
Registered
2004 gmc envoy_slt_xl
Joined
·
14 Posts
Discussion Starter #2
I forgot to mention i also tried prying with every size pry bar i got...

:coffee currently on break...
 

·
Banned
2004 gmc
Joined
·
26,181 Posts
Pry bars usually can't get enough impulse power for the C-clip. You're whacking on the tripot joint (looks like a can)?

It often takes at least a 3-pound, and sometimes 5 pound sledge.

Another tool made for the job has been discussed recently, and that's like a crows foot adapter to go on the end of a slide hammer. Harbor Freight or any sort of auto tool supplier.
 

·
Registered
2004 gmc envoy_slt_xl
Joined
·
14 Posts
Discussion Starter #4
yes on the tripod with a brass tap... also with a 3lb sledge... i'll try pick up 5lb see what happens...

tnx for reply ...
 

·
Registered
2002 chevy trailblazer_ls
Joined
·
1,433 Posts
I used a prybar on mine. Hooked it between the tripot and the housing and gave it a yank. First time it slipped off since I didn't have it straight, but the second time it popped right out. Seemed easier to me than trying to beat on it with a sledge.

 

·
Registered
2004 gmc envoy_slt_xl
Joined
·
14 Posts
Discussion Starter #6
5lb did not work i'll try with that kind of pry bar...

Is it possible that who ever installed it mess up the clip by hammering in???

and you guys did work on the driver side correct???
 

·
Banned
2004 gmc
Joined
·
26,181 Posts
Hard to mess up the clip. The driver's side is usually 3 times easier than the passenger's side because the driver's side is constantly bathed in differential oil. Passenger side is dry. You've checked your diff fluid level by way of the fill hole yet? As soon as you remove the CV shaft it will drool out the hole if you're filled to the proper level.
 

·
Registered
2004 gmc envoy_slt_xl
Joined
·
14 Posts
Discussion Starter #8
Thats what i figured it should be easier i've change the shaft on passenger no Problem...

But driver side is giving me hell...

and yes i have checked the fluid and added twice already... due to the leak from the seal...

real pissed off i'm thinking of sending it out... maybe a real mechanic can get it out... :) give them the problem...:duh:
 

·
Registered
2002 gmc envoy_slt
Joined
·
539 Posts
Have you confirmed its leaking from the axle seal? I thought I also had a leaking seal and after cleaning everything around it thoroughly, it turned out to be the fill plug o ring leaking slightly.Oil was working it's way back from the wind driving it back around the seal and down on to the oil pan shield. I was getting ready to pull the axle and thought I'd just clean it all up first and see where it was coming from. Drove around for a day or two and Sure enough...fill plug. New O-ring, no leaks. HTH c good
 

·
Registered
2004 gmc envoy_slt_xl
Joined
·
14 Posts
Discussion Starter #10
i wish it was just the O ring that would make me real happy ... but its getting so i'll check again tomorrow... try to hammer some more hehehe arm already sore...
 

·
Banned
chevy
Joined
·
1,091 Posts
If that brass punch is deforming at all you are losing a lot of the energy of the hammer.

Use something steel... you won't hurt those joints. I use a pickle fork.
 

·
Registered
2004 gmc envoy_slt_xl
Joined
·
14 Posts
Discussion Starter #12
Ok back to work on this seal...

I'll try metal steal today like u said... keeping fingers XX
 

·
Registered
2004 gmc envoy_slt_xl
Joined
·
14 Posts
Discussion Starter #13
Still din't come out tried everything i could think of...

I decided to top up the oil for now and close everything back up...

I'll update ASAP when job is done...

Thanks for all the help

This is crazy... :crazy: I've never given up before this is the first...

Well maybe i'll try again another day...
 
1 - 13 of 13 Posts
Top