Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

61 - 65 of 65 Posts

·
Registered
2002 gmc envoy_slt
Joined
·
33 Posts
Thank you, I will. I had it pulled apart the other day and had full 12v at the power plug (4 wires) from the firewall/frame and that even powered up into the module. Did your KeyFab still operate the other 3 doors?

This is just one in a chain of electrical gremlins I've encountered over the past 3 months.

((( Initial ABS/Brake lights dinging constantly. [replaced wheel hubs]

Fuel pump ground going out leading to stalling while driving and no start issues and a new fuel pump [ which still didn't start till we fixed a couple grounds, replaced Ignition switch, Cam Sensor, MAP sensor, swapped entire fuse box, new battery].

Fuel Gauge occasionally decides it wants to work. RPM gauge has done the same.

Fog Light button pressed/depressed turns the radio lights on and off.
Cruise Control works for 10-15 seconds and shuts off.
I've had the shifter button lock on me after putting it into park and not shutting off the truck and trying to shift back into Drive. )))

I keep telling myself it's a good new-to-me truck once I figure this electrical out.:bonk::bonk::bonk:
That sounds like quite an electrical problem. My keyfob still unlocked the other doors. Your numerous problems could be all connected. Possibly a main ground somewhere. Firewall, block, but I would definitely check all the wiring running through the rocker panels. Very easy place to collect salt, rust and dirt. Good luck. These are great vehicles. I've had my '02 since 2005 and still going strong...
 

·
Registered
2004 chevy trailblazer_ls_ext
Joined
·
12 Posts
This was a good-deal upgrade from my 1996 Blazer 4.3 Vortec...Was hoping for the same longevity luck on this one, which I think I can achieve if I find this gremlin. (just typed out my novel on the main forum) Thank you for your advice and reply, I'll be digging deeper this weekend with more time on my hand now.
 

·
Registered
2005 chevy trailblazer_ls
Joined
·
1 Posts
I have an issue I am not sure it is the module but other people suggesting it is.. it's driving me absolutely nuts. Happened 5 days ago. My driver side power windows front and back wouldn't work . My nephew checked my fuse and the fuse/relay whatever it is was really hot. My nephew had to use the sleeve of his shirt to get it out. So for the mean time he took the fuse out of passenger side and placed it in driver. Great I have windows that work. I had the truck running while he did this and when I went to auto zone to replace the missing fuse I shut the truck off. Now it wouldn't start. Took fuse out of the slot for the driver side it started right up. Issue has gotten much larger since. I kept the fuse out but in the meantime my dash is going nuts. All the icons are going on and off. The gauges are dipping . It is even affecting the radio. I couldn't take the headlights off of bright this morning. So I had my nephew switch the passenger side ddm to the driver. Still wouldn't work. So I has him unhook the ddm completley. Great lights and gauges back to normal.. silly me, not for long. Next time I started it up the lights are back on. Only good thing is the beeping like the door is open. That drove me nuts. So far no beeping. But now gas/battery/water/oil not working. Before it was disconnected these issues came and went constantly there was no break. But now with it unhooked the gauges are dead. I know I have a full take of gas. But gauge says empty. My air bag light , brake, antitheft, battery light etc. All back on. No radio at all, and no passenger windows. I will say I noticed if I put a fuse for the driver windows which I have left empty since thursday I hear a crackling noise in radio speaker. I will take fuse in and out and each time I hear a cracking in the left radio speaker. Right now I am very limited on money, so I can't afford a garage. I am desperate for an answer. My trailblazer has always run great. If I have any issue I take care of asap. My nephews or a friend of my sons will usually take care of any issues. But this is electrical not like replacing a fuel pump. So I am desperate for an answer it is driving me nuts.. please anyone have an answer to my dilemma I would appreciate it, thank you!!
 

·
Registered
2008 chevy trailblazer_lt
Joined
·
13 Posts
Late to the party but, my turn, '08LT TB

Things that just quit working(that I know of, wifes TB).

Front passenger window, knew about it for about a month. I put a regulator in maybe 18 months ago. Already had it back together before I realized the up and down were reversed but it has worked fine like that since.

Rear tailgate lock(FOB operated), had been getting mechanically louder soooo. Noticed yesterday that it wasn't working at all. That's when I noticed the---

Front passenger lock(FOB operated) wasn't working but not really sure when this started, maybe when the window quit but not sure.

And last, the radio shuts off right when you turn the motor off.

Other than the passenger window not working, the wife was unaware of the other issues.
She just thinks she has been locking the doors:yes:

So, is there a common denominator here or multiple issues.
I haven't touched anything yet, just doing some CSIing
And I have read all 7 pages.

edit: the passenger rear view mirrors wont adjust either. Time for a PDM??
 

·
Registered
Joined
·
1 Posts
I just came across this issue with 06 trailblazer. I had to replace the A/C resistor and after that none of my windows work the power door lock do work and mirrors don’t work either. I check all the fuses and checked if there was power going to switch and there is. I swap the one on the passenger side to see if that would work and nothing. I also tried one from the kick yard and still nothing is happening. A friend of mine has the Matco Maximus scan tool and when I hooked it up it didn’t detect neither the driver side or passenger side door modules. Can someone please help out not sure where to go from here.
 
61 - 65 of 65 Posts
Top