Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 3 of 3 Posts

·
Registered
2002 gmc envoy_sle
Joined
·
2 Posts
Discussion Starter #1
2002 GMC Envoy with 159k. Starting it up has no problem and engine runs. Push on the gas and it revs up. Putting it in ANY gear and it just does not move. For a while there was a clicking noise under the vehicle, which i thought was the transmission. It started to die out on the freeway with a loss of power and I had to pull over and have it towed. That infamous clicking is now gone even though the envoy starts up. There was loud knocking coming from behind the dashboard after starting the engine. It would go on for 4-6 knocks and stop. While driving it I would start up the air conditioner and set it to "face" and not the feet or combined setting, I would hear that loud knocking again. I have gotten all kinds of feedback from people, just replace the whole transmission and so forth. need some advice.
 

·
Registered
2006 chevy trailblazer_ls
Joined
·
389 Posts
The knocking sound is likely the all-to-common hvac mode actuator failure and is unrelated to your transmission.
HVAC Mode Actuator Replacement

As for the transmission:
When you put it into gear do you hear/feel anything? (i.e. does nothing happen or does it feel like it's going into gear and just not moving?)
Does shifting into neutral allow you to roll?
What's your trans fluid level/condition? When's the last time it was changed?
Has the transfer case fluid been changed at the required 50k intervals? Is it full?
 

·
Registered
2002 gmc envoy_sle
Joined
·
2 Posts
Discussion Starter #3
reply

transmission fluid looks good replaced in oct 2010, as well as a tune up, serpentine belt change and all fluids changed. Have had it done on its intervals. as far as putting it into gear, yes it does roll when in neutral. the transfer case fluid i would have to double check on to make sure IT was done also but as far as i remember it was done.
 
1 - 3 of 3 Posts
Top