Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
I have a 2009 Chevrolet Trailblazer LT 4.2l L6 4x4 with 4L60-E transmission. Built in Canada. Every time I accelerate my stabilitrak on light comes on and goes away. Once before I had service stabilitrak, traction on, Engine reduced power lights and I could not accelerate like normal. I couldn't go over 20mph. I took apart the throttle body, cleaned her, replaced intake manifold gaskets, shop said I needed both rear wheel sensors. I got them replaced and it still happens. This time they said it was the steering position sensor in the steering column. My question is, WHICH PART NUMBER DO I NEED???? There are two OE numbers I keep pulling up and I don't want to accidentally get the wrong one and have to attempt to send it back with this Virus going around, we're going to have snail mail with alot of workers sick. Please let me know if I'm supposed to get part number 19150081 or 26104070.
 

·
Registered
2004 chevy trailblazer_lt
Joined
·
978 Posts
In looking at the part descriptions for the two ACDelco sensors listed on the rockauto website, it appears one sensor is for a 2009 $WD TrailBlazer with RPO option NP7. You need to check the sticker with the RPO codes for your TrailBlazer. It should be located inside your glovebox door. If you have option NP7, then you'll need to order Part Number 26104070.

Good Luck!
 

·
Registered
Joined
·
7 Posts
I have a 06 trailblazer LT and I want to but no higher than a 3 inch lift on the front 2.5 in the back or..... 2.5 front 2rear. My only problem is idk what size tire will fit this. I need some help I want a tire that fits perfect not to big and cranked but more just good amount of gap and everything
 

·
Registered
2004 chevy trailblazer_lt
Joined
·
978 Posts
traiLT06, I really think you would be better served asking this question in either the Tires or Suspension Subforum under the 02-09 Brakes, Suspension, Wheels and Tires area of this forum or beginning a brand new thread.

Good Luck!
 

·
Registered
2004 gmc envoy_slt_xl
Joined
·
77 Posts
Sorry, but there weren't any GM 360 platforms built in Canada. All the short wheel base models were built in Moraine, Ohio and the extended versions were built in Oklahoma City, Oklahoma
 

·
Registered
Joined
·
14 Posts
Discussion Starter #8
Sorry, but there weren't any GM 360 platforms built in Canada. All the short wheel base models were built in Moraine, Ohio and the extended versions were built in Oklahoma City, Oklahoma
My truck was manufactured and sold in Ontario Canada. Per VIN, door and good labels, parts and service book. I have this household plug hooked up to my battery and block.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #9
I still have not gotten the stabilitrak issue figured out. Rear sensors replaced, angle sensor replaced and she still isn't right. I'm about to replace the front ones I guess, and hope that stops the problem. Otherwise it's got to be the damned throttle body. I looked in the set ice book and seen the stabilitrak wiring goes to the fuse block under the back seat, but there's no fuse or relay specific.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #10
Update to my post, I finally found a decent mechanic, after previous ones lead me on a trail, the very last front passenger sensor is a slow responder. Now that it's snowed and I can feel the others working, she is not engaging. Issue resolved. Finally.
 
1 - 10 of 10 Posts
Top