Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 4 of 4 Posts

·
Registered
2004 chevy trailblazer_ls_ext
Joined
·
14 Posts
Discussion Starter · #1 ·
Pattern happens every time. In the morning the cruise does not work. Turn the TB off and back on, cruise works. Any ideas? Searched forums and couldn't find my symptom exactly.
 

·
Registered
2004 chevy trailblazer_ls_ext
Joined
·
29 Posts
Me too

Mine will occasionaly decide it doesn't want to hold the pedal for me either. Very sporadic, but when it happens, turning the engine off and starting it again does the trick. It's aggavating if you've just got on the interstate or just got up to speed on the hwy. Mine acts as if nothing happened-no functionality, no "cruise" light on the dash either.

Sorry, but I don't have a solution.
 

·
Banned
2004 gmc
Joined
·
26,181 Posts
There are a lot of non-urgent PCM codes that will disable the cruise control as an annoying "hint" to get things looked at. Not urgent enough to light up the service engine soon lamp, but they store codes in memory. The PCM also stores the last few reasons that the cruise control shuts off, like brake pedal, overspeed, etc.

That can help troubleshooting intermittent issues. But most parts stores scanners won't report those memory codes. You may need a dealer or a high-end independent mechanic with a scan tool to look deeply into the PCM memory.
 

·
Registered
2004 chevy trailblazer_ls_ext
Joined
·
14 Posts
Discussion Starter · #4 ·
result

I had the battery disconnected for about 2 hours while I was working on something else, and the cruise started to work every time now. Dang Gremlins
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top