Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 9 of 9 Posts

·
Registered
2004 gmc envoy_slt
Joined
·
12 Posts
Discussion Starter · #1 ·
I noticed today there is a coolat leak in my 04. I can not see exactly what it is, but it is coming from directly under the engine. When I park I see it dripping but can not see exactly as there is a plate or guard in the way.

So looking to see what it could be and what my cost range will be

Head gasket?
Water Pump?
Heater core?

Thanks in advance for the help.
 

·
Registered
2005 chevy trailblazer_ls_ext
Joined
·
2,667 Posts
We don't have enough information. Directly under the engine doesn't really tell us much. It is coming from the front of the engine area, the rear or what?

Are you sure it's coolant? What color is it?
How many miles are on your vehicle? I6 or V8 engine?

Water pumps are fairly common failures on these vehicles.
 

·
Registered
2004 gmc envoy_slt
Joined
·
12 Posts
Discussion Starter · #3 ·
We don't have enough information. Directly under the engine doesn't really tell us much. It is coming from the front of the engine area, the rear or what?

Are you sure it's coolant? What color is it?
How many miles are on your vehicle? I6 or V8 engine?

Water pumps are fairly common failures on these vehicles.

It is towards the year. I am 99% sure plus the resovoir is empty and I filled it a few weeks ago. This is the i6. THere are 116500 miles on it.

I did notice now that the car has sat for an hour and cooled down it is not leaking. I pushed it back and saw nothig else comig out. I opened the radiator cap and its full, just the resovoir. Could it be leaking from that?

What am I looking at if its the water pump
 

·
Registered
2005 chevy trailblazer_ls_ext
Joined
·
2,667 Posts
Depends - if you do it yourself the water pump isn't that expensive - 50.00 to 60.00

I haven't changed mine yet, but it doesn't look that hard. Probably the worst part would be taking the fan clutch off. This subject has been discussed here a lot and I think we may even have a sticky for doing it - the fan clutch that is.

The reservoir could be leaking, but my guess would be that you have a leak somewhere else and the system is just sucking the coolant from the reservoir tank into the radiator. That COULD be why the radiator is full and reservoir is empty.

As for the dealership costs - I would GUESS at least 2 hours of labor plus whatever they charge for parts, which I guarantee will not be 50.00
 

·
Registered
2003 chevy trailblazer_ls
Joined
·
5,268 Posts
Since your reservoir is now empty...
IF you have a leak somewhere else... and you continues to leak..
when it sucks in stuff from the reservoir- it will suck in air.. since its empty.
You dont want air and dexcool mixing... it will cause it to sludge.
so- I would add dexcool to the reservoir- and also try looking for that leak
 

·
Registered
Joined
·
137 Posts
If it's toward the rear of the engine look at the heater hoses where they go in the cabin. Check it running and warmed up good with the heater on.
 

·
Registered
2003 chevy trailblazer_lt_ext
Joined
·
1 Posts
This is my LEAK

2003 Chevy Trailblazer EXT 94,000 miles

-Reduced engine light comes on when traveling up hills
-there is usually a puddle underneath it after parking it
-I have to refill the coolant every 3 weeks

does this sounds similar to your problem? did you fix your problem yet?

 

·
Registered
2003 chevy trailblazer_ls
Joined
·
74 Posts
My leak is the same

2003 Chevy Trailblazer EXT 94,000 miles

-Reduced engine light comes on when traveling up hills
-there is usually a puddle underneath it after parking it
-I have to refill the coolant every 3 weeks

does this sounds similar to your problem? did you fix your problem yet?


My leak is the same. My overflow is filled up and then I filled up the radiator and then the leak from the bottom as this pic shows slowly drips. I don't know where it's from. Maybe need to replace the T-Stat again? I already replaced it back a few years ago. This truck runs great when it's working but this now combined with my odometer & gear selector not working again after being fixed by http://www.gmgaugeguy.com/ is really causing a slight headache to start for me.
 
1 - 9 of 9 Posts
Top