Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 3 of 3 Posts

·
Registered
2002 gmc envoy_slt
Joined
·
33 Posts
Discussion Starter · #1 ·
Went out this afternoon to fire up my '02 Envoy SLT. Temps last night were -20C. When I tried to start the truck it was -14C. Turned over twice then went click, click, click. Clock went to 12:00 but radio stations stayed put. CD changer started making noises like searching discs.

Put the charger on battery (battery is about 5 years old, Everready) and then got in my '12 Acadia SLT to start it up (new battery last month) Started no prob. Went back to the charging Envoy (this is like 2 minutes later) Charger says full charge. Tried her and she started right up.

At this time (and a few other times that I actually looked at the volt meter) it was showing about 6 - 8 volts for 2 -3 seconds, then a full 13-14 volts.

Doesn't seem to me that the battery is bad if it took a charge this quickly. Is there anything else that could cause this condition?

Glenn...
 

·
Registered
2002 gmc envoy_slt
Joined
·
33 Posts
Discussion Starter · #4 ·
Thanks for the reply Guys. I figured it might be the battery but the quick recharge had me puzzled. I have another battery I bought off a neighbour when he junked his car. Problem is it has top posts so I was going to bay a set of side -to-top post converter cables. Battery was bought new this summer. I think it is a 650 CCA. Physical dimensions are the same. Just spent $130.00 for a new battery for the Acadia so another is not in the budget and am hoping this will work.

Again, thanks for the answers...

Glenn
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top