Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 13 of 13 Posts

·
Registered
2002 chevy trailblazer_ls
Joined
·
19 Posts
Discussion Starter · #1 ·
I've searched all over this site to find a similar situation or cause, to no avail. I just cleaned my very dirty throttle body and now it seems my MPG dropped by at least 2 MPG. I was getting over 17 MPG and now I'm getting 15MPG combined. After the throttle body cleaning I also put new plugs in. No change in MPG. Looking at other posts here's what I've considered/checked:
The drive selector is in 2WD and not stuck in 4WD or something. At least I've cycled it several times and I hear the 4WD engage and then disengage. The thermostat is good. Engine running consistantly at 201 degrees. I don't have a lead foot. I have an 02 TB with 67,000 miles. Always get my gas at the same two places Costco or Giant Food stores. Have a K&N CAI and it is cleaned pretty regulary. I check my mileage pretty much at every fill. Very consistant MPG since I've owned the TB until now just after the throttle body cleaning. ANY suggestions? I do have an Interceptor gauge (plugs into the code reader slot) mounted on the dash so I can see what is going on at almost any time. Anything I can check on that while driving?
 

·
Registered
2007 chevy
Joined
·
67 Posts
Dirty MAF?
 

·
Registered
2008 chevy trailblazer_ls
Joined
·
10 Posts
Kinda weird, my 08 did the same thing. Was getting 18.5-19.5 mpg then after the throttle body cleaning it went down to 16.5-17.5mpg. I did unhook the battery while I was doing it, and cleaned the MAF at the same time with MAF cleaner. I figured it was just a bad tank of gas but it's been through 3 tanks so far and it's still 2 mpg or so down from what it was.
 

·
Registered
2007 saab 9_7x
Joined
·
3 Posts
Do you have to disconnect the battery? Won't the computer eventually learn that it's cleaned and adjust? Clearly it would be faster to disconnect, but I'm just curious.
 

·
Registered
2002 chevy trailblazer_ls
Joined
·
19 Posts
Discussion Starter · #8 ·
Did disconnect the battery. Haven't changed the O2 sensor. SHOULDN'T be a plugged CAT with 67,000 miles. No codes. Tire pressure always checked. Driving me nuts!
 

·
Registered
2002 gmc envoy_slt
Joined
·
3,203 Posts
Did disconnect the battery. Haven't changed the O2 sensor. SHOULDN'T be a plugged CAT with 67,000 miles. No codes. Tire pressure always checked. Driving me nuts!
Wanna bet? Mine clogged around 34k......the 02 & 03 models have a smaller converter and no AIR pump to cool them. Teltail sign is the motor is resistant to rev to the 6200 rpm shift point at full throttle from a stop. - Takes forever for the CEL to set, usually when vehicle is barely drivable.

Have you changed anything else? New tires or other mods?
 

·
Registered
2002 olds bravada
Joined
·
6 Posts
Maybe the dirty throttle body was causing a "lean" condition, thus reducing the amount of fuel sent to the engine...

I remember how much slower my Olds 88 would be when the tb was dirty :x
 

·
Registered
2003 gmc envoy_slt
Joined
·
4 Posts
Same here

Pulled off my tb yesterday and cleaned it to near spotless, put 120 miles on it today , and the mileage has dropped. From 19.8/20.1 down to 16.5/16.8.

Pulled the battery lead for about an hour, but by that many miles shouldn't it have relearned by now ? It was more then a full drive cycle.

I run a synthetic blend in the oil. Anything else we can do to increase the fuel mileage ?
 

·
Registered
2002 chevy trailblazer_ls
Joined
·
19 Posts
Discussion Starter · #12 ·
O.k. here's my thought after 125 highway mile trips to our lake house. It WAS the lead foot. After cleaning the throttle body and replacing the plugs, the car just "felt" full of pep so I would run 70+mph (where legal). This past time I ran at 65mph and got the mpg back up to 17 from 15. Also minded the at or below 2500 RPM on hills etc. This was also after two tankfuls. So maybe it took that long for the computer to "re-learn" the proper mixture????? Whatever, it seems like the 02 TB is back on track. Thanks for all the inputs.
 
1 - 13 of 13 Posts
Top