Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 3 of 3 Posts

·
Registered
2007 chevy trailblazer_ss_3ss
Joined
·
1 Posts
Discussion Starter #1
I’ve owned my TBSS since it was practically new and in the last year I’ve notice I have the flickering light issues many have had in the past. I’ve been doing research on old threads it seems like NO ONE has ever figured out a direct cause. The best answer I got was a new fresh battery got rid of the issue. When the batttery gets older the problem generally can come back. There’s surely more to it than that?

So far what I’ve done...

-swapped alternators twice with Reman Ultimas from OReillys
-Swapped in a new Duracell AGM battery from Sams
-installed, removed, reinstalled PCMofNC 3 wire upgrade.
-checked grounds.
-my TBSS has NEVER been wrecked

What has actually worked for people who have had this issue?

BTW, I don’t have a Cam or a stereo. Only electrical mods I have...

PCMofNC 3 relay Spal electric e-fans, Magnuson Intercooler Pump, Devilsown Alky Injection Kit, Aeroforce Gauge, AEM wideband, Boost gauge lighting.

Surely I’m not due for a bigger alternator?



Sent from my iPhone using Tapatalk
 

·
Registered
2005 chevy trailblazer_ls_ext
Joined
·
80 Posts
before buying yet another alternator, I would see what the voltage is with a voltmeter. Also is it fluctuating or steady. If it is putting out 14v (about) and steady, I would rather doubt it was the alternator. As far as a diagnosis, I am not able to advise much. I might check out the cables to the battery. At the battery AND at their respective connections. Sometimes, (I have had this happen), the cables go bad and this leads to intermittent issues. BEST
 
1 - 3 of 3 Posts
Top