Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Are the 2002 and 2005 transmissions interchangeable? A little late to ask if not but my car is just not running as smoothly. seems to me that it is taking much longer to change gears. Also, now my cruise control does not work and my dash light under the P N work but the D 1 2 3 do not! Could that really only be a fuse like the mechanic said or is something different between the two vehicles which both have cruise control? Both 4X4 also. Help!:confused:
 

·
Registered
2009 chevy
Joined
·
6,431 Posts
Your not providing much info, but your "A little late to ask if not" comment leads me to believe that you have already changed the transmission.

I doubt if you have blown a fuse (at least as far as the roughness is concerned). It's probably a dirty throttle body. Try a search and read about it.

The cruise control is probably a separate item. I'll dig out the drawings.

If they are connected, there may be a vacuum hose knocked off.



Ok, my 3rd try at editing this post.

EDIT

New member, we ask the new members to fill out the vehicle profile so that we won't be guessing when we try to answer a question.

As you have not completed this task, I'm forced to guess, so here goes.

You have a 2wd truck................... and perhaps, the tranny came from a 4x4 truck.

Yes they are the same transmission except for...............................

The cruise control requires info from the speed sensor circuit. In the 4wd trucks, this sensor is located in the transfer case, in the 2wd trucks, the sensor is in the tail piece. Your transmission may not have the sensor, or it might be disconnected.

Either would also cause the ABS light to come on.

If my guess is wrong, check the fuses.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
Thanks to all...

I did not check the fuse yet but will do that, just wanted to get a couple of opinions. The sensor issue may be exactly the problem. I will also look into your suggestion on the throttle body. But I did specify that both transmissions were 4X4, so difference in that is not the issue. Thanks again for helping me with this. I will get all of the rest of my profile completed.
 

·
Registered
2009 chevy
Joined
·
6,431 Posts
Ok, thanks for filling out the profile.

You have a 4wd truck, so my guess is no-where correct. sorry to use up a post :laugh:.

If there is a speed sensor problem, I think it should throw a PCM code :undecided.

But that is the only thing working on the tranny might disturb. I assume, the cruise worked before the swap.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #8 ·
Thanks again to all who helped...

...yes, the cruise and the gear lights on the dash all worked. Busy weekend with kids stuff, so I still haven't quite had a moments time to check any of the recommendations out. I will this week and I will let you all know what the fix is because I am sure that at least one of the recommendations is correct. Have a blessed week all!:thx
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top