Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 20 of 142 Posts

·
Registered
2009 chevy trailblazer_lt
Joined
·
1,716 Posts
First off i need to thank Justin @ Advance Automotive for figuring this out.
Since TB is new, did not want to start attaching wires etc. might void warranty.
This worked on my 09. all lights work as they normally would except when you flip your brights lever forward all 4 come on, or w/ fogs if you wire those too. also all are on when you flash to pass.

parts needed: 2 diodes. available @ radio shack # IN4004 1 amp Diodes,400V,30amp max return voltage. .99 - 1.99 for pkg of 2

helpful: needle nose plyers, flashlight, magnifing glass.

this is all done in the Body Control Modual (BCM) under the drivers side rear seat.

1) disconnect Battery ! if you dont and are testing other slots, a lot of codes will happen and set off security thing. that means a trip to dealer to clear all codes.

2) open up cover on BCM, if dont have or want fogs on w/quads, unplug the
LOWER harness

3) find pink/white wire(headlights) insert one end of diode into that slot

4) find black/white wire(brights) inset other end of diode into that slot.

note -the silver or silver striped end goes to the BLACK /WHITE wire on the LOWER harness, other end to PINK/WHITE wire

5) plug harness back in

6) if you have and want fogs on also, unplug UPPER harness, find green/white wire(fogs) and plug one end of OTHER diode into that slot.

7) plug UPPER harness back in and take the open end of the diode you just installed and wrap it around the exposed wire of the diode on the LOWER harness.

note - the non-silver or non-striped end goes to GREEN/WHITE wire in UPPER harness, the silver or silver striped end ties into the side of the diode going to the PINK/WHITE wire

8) reconnect battery and test

this worked on my 09 TB, have had wired since March w/ no problems so far.
can't say for shure wire colors are same on older models, but should be unless GM had a bright idea and switched colors around.

Hope this will help other TV members who want quads, but afraid of warrany issues. no one will see unless the get into the BCM.
 

Attachments

·
Registered
2004 gmc envoy_slt_xl
Joined
·
1,393 Posts
NICE !!!! :hail:

So .. lights work normally? .. auto on/off? ..(with dash switch manual control as well?) entry/exit? Fogs?

Yet when you flip your high beams on, all 6 lights stay on? (only highs and lows if your fogs are off?)
 

·
Registered
2009 chevy trailblazer_lt
Joined
·
1,716 Posts
Discussion Starter · #3 ·
yes,all lights work normal just like they did w/ exception of fogs. they work normal w/ fog switch but once you turn on brights all 6 lights on, cannot turn off fogs w/ brights on. also flash to pass all 6 come on. but for me thats why i wanted quads w/ fogs.... more light on dark roads
 

·
Registered
2004 gmc envoy_slt_xl
Joined
·
1,393 Posts
COOL !!!:thumbsup: NICE !!:thumbsup:

But here is a question for ya .. maybe I am wrong, but arent diaodes polarity/one way devices? As in a positve and negative end? If so (and like I said it has been many years) which end did you connect where? AS in polarity wise. I see the colored band int eh one pic but cant make it out in the other
 

·
Premium Member
2007 chevy trailblazer_ls
Joined
·
1,456 Posts
So when can I come by and have you guys do mine. :rotfl: Just kidding looks good and definately in my plans.:thumbsup:
 

·
Registered
2003 chevy trailblazer_ls
Joined
·
1,248 Posts
That is a nice, and simple mod. Good job.

I did mine the old-fashioned way, with a pair of relays, a switch for the fog lamps (mine didn't have factory installed fogs) and a few pieces of wire. Love how it works. I have 6 lamps when I want them, or fogs separately if that is what I'm wanting. DRL still works. Only issue is remembering to switch off the fogs, or they will continue to burn.
 

·
Registered
2002 olds bravada
Joined
·
2,383 Posts
another great mod for those who have HIDs in their highbeams!!! :thumbsup::thx
 

·
Registered
2002 chevy trailblazer_ls
Joined
·
371 Posts
Let me get this right...

Pardon me, electrically challenged here, but you INSERT into the slot. No cutting, right?

And this works?

Neat.
 

·
Registered
2009 chevy trailblazer_lt
Joined
·
1,716 Posts
Discussion Starter · #12 ·
correct, no cutting. just insert it into the wireslot you are connecting to.(pink/white,black/white,green/white) and it should contact the metal of the plug. it should be snug.
 

·
Registered
2002 non_gmt360 other
Joined
·
1,071 Posts
Similar to what I did but different, lol. I had HIDs installed in lows and fogs, and I added relays for them ( best way to install them since you aren't using factory wiring to power new lights, just to turn on relays), so I was able to put my diodes onto the power wire for the relay going to my fogs and for the quad beam I used the article in the how-to section and went under the steering column and moved a wire so my high was the flash to pass.


I mostly wanted the 6 lights since when you put your highs on your fogs turn off and when you go back to low, the HID fogs have to turn on again and warm up, not to mention it is hard on the ballast.


I like your way better though since you can do it all with 2 diodes and from the rear fuse box. Might just have to try out the fog option and I can remove my diodes up front.
 

·
Registered
2009 chevy trailblazer_lt
Joined
·
1,716 Posts
Discussion Starter · #15 ·
to all that have looked at this post. i screwed up! i was going by what justin(the guy that figured this out and installed it) told me. had a member pm me to verify what reply #5 stated. silver or silver striped end of diode goes to pink/ white wire. i was told wrong! while trying to look at it and figuring out what went where, i accidently pulled out the lower diode. so for the next 45 min in my 95+ degree garage i got it to work again. as the picture appears in my original post. the silver or silver striped end goes to the BLACK /WHITE wire on the LOWER harness, other end to PINK/WHITE wire. if fogs involved,
the non-silver or non-striped end goes to GREEN/WHITE wire in UPPER harness, the silver or silver striped end ties into the side of the diode going to the PINK/WHITE wire. sorry for any confusion this may have caused any one.
 

·
Registered
2004 chevy trailblazer_lt
Joined
·
287 Posts
Well I haven't seen anyone with an older style reply that it worked yet, but for this price I am going to be heading to Radio Shack tomorrow. Love the look just never wanted to start cutting my wiring(makes me nervous) I will let you know how mine works!
 

·
Western Canada Chapter
2003
Joined
·
6,421 Posts
to all that have looked at this post. i screwed up! i was going by what justin(the guy that figured this out and installed it) told me. had a member pm me to verify what reply #5 stated. silver or silver striped end of diode goes to pink/ white wire. i was told wrong! while trying to look at it and figuring out what went where, i accidently pulled out the lower diode. so for the next 45 min in my 95+ degree garage i got it to work again. as the picture appears in my original post. the silver or silver striped end goes to the BLACK /WHITE wire on the LOWER harness, other end to PINK/WHITE wire. if fogs involved,
the non-silver or non-striped end goes to GREEN/WHITE wire in UPPER harness, the silver or silver striped end ties into the side of the diode going to the PINK/WHITE wire. sorry for any confusion this may have caused any one.
Maybe repost with all the correct steps in one post to make it all clear without the errors in the original post :thumbsup:

Or for $24 you can plug and play
http://forums.trailvoy.com/showthread.php?t=36674&highlight=mrtaillight.com
 

·
Registered
2007 chevy trailblazer_lt
Joined
·
113 Posts
is this for real...when done correctly, is there any chance of melting wires or messing anything up. Im electronicly stupid, but a 1amp diode, with 30 amp max return voltage? Is that right...400 Volts...is that right? Just how much voltage and current is going through these wires? I dont wanna mess up my new ride...i just got her and i love her...i dont wanna break her. Thanks for dealing with my paranoia.

Shane
 

·
Registered
2009 chevy trailblazer_lt
Joined
·
1,716 Posts
Discussion Starter · #19 ·
yes it is for real. and i understand your hesitence. i've had this set up since mid march on my brand new tb.
have not have any issues what so ever. i did have a fog light burn out, but don't think it had any thing to do with the set up. just make sure you disconnect the battery before you do this. my battery was not disconnected when we trying to figure out what wires were what, and it threw a bunch of codes at the compter and set off the security warning light on dash. had to go to the dealer to have them all cleared. good luck
 

·
Registered
2007 chevy trailblazer_lt
Joined
·
113 Posts
yes it is for real. and i understand your hesitence. i've had this set up since mid march on my brand new tb.
have not have any issues what so ever. i did have a fog light burn out, but don't think it had any thing to do with the set up. just make sure you disconnect the battery before you do this. my battery was not disconnected when we trying to figure out what wires were what, and it threw a bunch of codes at the compter and set off the security warning light on dash. had to go to the dealer to have them all cleared. good luck
Thanks alot Fletch...u were right on the money. I did decide to use quick connects and set up for quads+fogs, but i didn't hook up the fog wire just yet. Im going to see how i like it with just quads first. If i decide i want more light, all i have to do is plug the other installed diode to the quick connect already installed on the fog wire. I used a 3pk of 18-22g quick connects, and the diodes u listed. And i can plug and unplug as i wish by flipping the seat and poping the fuse box covor.

Shane:thx
 
1 - 20 of 142 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top