Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 8 of 8 Posts

· Registered
2004 chevy trailblazer_lt
Joined
·
15 Posts
Discussion Starter · #1 ·
New to this site and have found some great info, so thanks to everybody! I have an '04 Trailblazer that I bought new and have been extremely happy with it. I did encounter one problem when I was going to tow it when I was moving. After trying for several hours, I could not get the transfer case into neutral to disengage the rear axle. I remembered that there wasa time that my mother had driven my car once for about 100 miles in 4HI and wondered if that might have something to do with it. I used the directions for shifting into Neutral as described in the owner's manual, but to no avail. I have about 90k miles on the vehicle and have never gotten the diffs serviced. Any thoughts? Ideas?
 

· Registered
2003 chevy trailblazer_ls
Joined
·
1,834 Posts
Mine gets picky once in a while. You need to run the switch back and forth ,with the engine off, lots of times. The contacts get dirty. Even though the light goes off does not mean the TC is in N. Shift into park and see if the truck will roll. Last time I had a problem I turned the key on, then tried to put the TC into N and that worked.
 

· Banned
2004 gmc
Joined
·
26,436 Posts
The neutral position of the transfer case selector switch is the most likely to get oxidized since it's used the least. Does it light up the neutral mode light when you run through the owner's manual procedure?
 

· Registered
2004 chevy trailblazer_lt
Joined
·
15 Posts
Discussion Starter · #8 ·
Sometimes the Neutral indicator light would come on, though the transfer case was still engaged. At other times it would not. I've had trouble with the position light as well (ie. indicating TC is in 4HI when it has shifted into 2 wheel after driving on ice), but I've been able to resolve that by toggling the selector switch.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top