Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
When I apply the brakes at any speed they grind and shake horribly. Feels like the wheels are going to fall off. What could this be? I just had new brakes and roters put on.
 

·
Registered
2002 chevy trailblazer_ls
Joined
·
4,125 Posts
Have you checked the whels to make sure they aren't gonna fall of yet? I have to ask. I see it alot at work.

Only when the brakes are applied? What if you lightly apply them? Do they still shake violently or less?

Sounds like a really warped rotor or the wheels are gonna fall off. How long ago did you get the work done?
 

·
Registered
2003 chevy trailblazer_ls
Joined
·
1,708 Posts
I assume that the noise was not there before the new brakes. Did you or a shop do the work? I have seen a couple of people do their own work and install the pads backwards, yes, metal to metal. Sounds really bad when you apply the brakes.
 

·
Registered
2005 chevy trailblazer_ls
Joined
·
251 Posts
Have you checked the whels to make sure they aren't gonna fall of yet? I have to ask. I see it alot at work.

Only when the brakes are applied? What if you lightly apply them? Do they still shake violently or less?

Sounds like a really warped rotor or the wheels are gonna fall off. How long ago did you get the work done?

:iagree:
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
My dad did the work about 2 weeks ago and all seemed fine. We definately put the pads in right. torqued to 100 like my book says to do.
 

·
Registered
2003 chevy trailblazer_ls
Joined
·
1,708 Posts
So the shaking and noise was not there after the new brakes. How long after this did the problems start. Next day, next week ?
 

·
Registered
2003 chevy trailblazer_ls
Joined
·
5,268 Posts
you guys didnt lube the lugs nuts did you?
 

·
Registered
2003 chevy trailblazer_ls
Joined
·
1,708 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #9 ·
we didn't lube the lug nuts are we supposed to? The problem started this morning. I drove it last night and it was fine. The brakes are roters were replaced about two weeks ago. Everything worked fine.
 

·
Registered
2004 chevy trailblazer_ls
Joined
·
694 Posts
You might also make sure the calipers are lined up perfectly. If the pads dont sit in grove exactly right it will feel like driving down a speedbump test track when you hit the brakes.
 

·
Registered
Joined
·
2,819 Posts
Mine had a little shake in their step when i braked i found out that it was my rotors were warped a little and when i changed the rotors it stopped completely no problems anymore
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #12 ·
Got it all figured out and fixed. The rear brake caliper bracket bolt had fallen out and every time I hit the brakes the caliper would slip off the roter and scrape against the inside of the rim. Got a new bolt and put lock tite on all the bolts!!! I guess this was a problem with trailblazers and there was a recall for this problem.
 

·
Registered
2003 chevy trailblazer_ls
Joined
·
1,708 Posts
Did you use blue, green, or red locktite?
 

·
Registered
2002 chevy trailblazer_ls
Joined
·
4,125 Posts
a bolt missing in the rear caliper won't cause a shake. In order for a shake to occur the piston needs to get pushed inward and released constantly. Your rear caliper moving up and down won't do that. If the problem is gone then good but :m2: says it isn't that.
 
1 - 14 of 14 Posts
Top