Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I drive an 07 trailblazer. I get resistance from the pedal. Almost like a knock back where the pedal kicks up. I've got new rotors and breaks. My car also pulls to one side when I step on the brakes and to another when I let off. My traction control light comes on too. It flashes. Any ideas?
 

·
Registered
Joined
·
1,269 Posts
Seems like an ABS problem.

The "knock-back" is the ABS pump and solenoids firing to correct for a sliding or slipping tire.
 

·
Registered
Joined
·
1,269 Posts
Likely a bad tone ring or sensor - or wiring or a bad ABS unit - what codes does it show?
 

·
Registered
Joined
·
1,269 Posts
OKI - get a live stream then - you've got something goofy in the ABS system
 

·
Registered
Joined
·
1,269 Posts
You sent me a question - but it's not showing here .... so here goes....

You need to physically check everything if you cannot get a live stream.

Pull the front wheels and physically check all the wiring and connex and couplings.

That is - if you don't have test gear, you can do this the hard way. Just be prepared to pay money for parts as you guess your way through this system ..

Eliminating guesses is the reason for a scan. If you don't want to/have no access to a scanner - then load up the parts cannon.
 

·
Registered
2004 chevy trailblazer_ls
Joined
·
366 Posts
If this happens at a slow speed brake, the ABS is activating. Sometimes the wheel hub is bad, or the sensor in the hub is faulty, or has rust built up.
On some hubs, the sensor can be taken out and cleaned, make sure the mating surfaces are rust free. Mine were riveted in, so I had to get a new hub.
 
1 - 9 of 9 Posts
Top