Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 3 of 3 Posts

·
Registered
2005 chevy trailblazer_lt
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi, I just picked up a TB in rough shape but with low miles. So I'm to the part in the project where I fixed a rear calipar with a stripped bleeder valve and went to bleed the brake system. I have done this on many other vehicles before but this one with its ABS system is causing me some trouble.

I have got the pedal to give faily good pressure until I start the engine and then I have hardly any pedal pressure. I went back and this time with out the mighty vac, but with someone pumping the pedal and tried to re bleed the whole system starting from the lines coming out of the master cyl, then the lines at the ABS block, and then to the calipars again. Still little pressure at the pedal when engine is running but good when its off. Is there something I am missiing on this one? Help me out. Thanks in advance, love this forum already.
 

·
Banned
2004 gmc
Joined
·
26,181 Posts
Trailvoys traditionally have very soft pedal feel, even when they're working properly. But you may have a softer than normal or deteriorating flexible line in there somewhere, depending on the age and ozone level where it was living. See if you can find a working one to try out for a comparison.
 

·
Registered
gmc envoy_sle
Joined
·
15 Posts
YOU KNOW I AS WELL AM KIND OF HAVING THIS PROBLEM CHANGED THE M/S TWICE THINKING THAT WAS IT BUT DONT HAVE A PROBLEM STOPPING JUST WHEN IM SITTING AT A LIGHT MY FOOT STEADILY DROPS LIKE MY ABS ISNT WORKING I BLED THE BRAKE SYSTEM PUT ALL NEW FLUID AND SAME THING.......:weird:
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top