Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
So we had an unknown driver issue for awhile after months of headaches it turned out to be the OEM Bose head unit. Once it's unplugged we get our driver 1 or 2 again. Does anyone know what this could be ? Maybe the head unit having an issue or maybe the wiring causing it ? Please help my wife is frustrated not having music in the vehicle and this is out of my knowledge I don't know wiring or radios like that.
Thank you in advance.
 

·
Registered
2002 chevy trailblazer_lt
Joined
·
1,224 Posts
So we had an unknown driver issue for awhile after months of headaches it turned out to be the OEM Bose head unit. Once it's unplugged we get our driver 1 or 2 again. Does anyone know what this could be ? Maybe the head unit having an issue or maybe the wiring causing it ? Please help my wife is frustrated not having music in the vehicle and this is out of my knowledge I don't know wiring or radios like that.
Thank you in advance.

Besides the display of " unknown driver" were there any other issues?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
A whole lot of issues.
Lost door functions up front, back doors would roll up and down and the rear flap windows would work (we have the 3rd row extended) up front the locks wouldn't work, windows, the fob wouldn't do anything all the little gauges wouldn't work but tach and spedo did. Said unknown driver and it would constantly cycle through driver 1 for maybe 2 seconds then it would say unknown driver and everything would go back out but the truck ran and drove. We had to disconnect the battery because it constantly would cycle even with the key out and the truck was off and locked, once we plug the battery back in we can't start that truck till driver 1 would come on. Everytime it cycles with the radio plugged in when you saw the radio come back on that's when driver 1 would come back on, but like clock work only 2 seconds then unknown driver again. Oh and the radio is off and anti theft is blinking on it while we are driving.
Basically what I'm saying is all those month of not knowing what the hell the issue was the truck was on unknown driver 99 percent of the time, AC didn't work but the blower still pushed air out the vents just the condenser wasn't on . A whole lot of functionality goes out with it plugged in, for a couple months now we've just had the radio unplugged and put in the house.
With it unplugged the truck is as it should be, recently had the father in law take a look and we had a wire coming from the harness that plugs into the radio to the damn hazard lights ...... Who ever did that before we bought it spliced a wire from the hazard lights to the harness to the radio. Snipped that wire and plugged the radio back in immediately unknown driver still, in plug it bam driver 1 again. I am lost in this lol
 

·
Registered
2002 chevy trailblazer_lt
Joined
·
1,224 Posts
We have the factory Bose head unit I forgot to add that.

OK... Pretty much everything you mentioned for symptoms can be caused by a failure to communicate!

These trucks, like pretty much every vehicle today, are rolling computer systems. Every control system computer talks to every other computer system on the same one wire. Even the radio. And even if the radio is "turned off" it is actually still on. Like a cellphone screen, you can turn it off but it is not powered down. The radio is powered all the time. No way to change that without pulling fuses or cutting/disconnecting wires. If anything at all fouls up that one wire that the modules communicate on all hell brakes loose.

So on your 2002 with Bose there is an orange wire that is the communications wire. And right next to that wire at the radio end is another orange wire that is the 12 volt radio power from the radio fuse. The wire closest to the bottom of the radio is the communications wire. There can be NOTHING tapped into that communications wire.

Now you said there was some wire from the hazard lights tapped into the radio harness. Where? I would guess if someone hooked up some random wire that had power into the radio harness it could damage the radio module and that could cause the trouble. Or someone tried to tap into the orange radio power wire and got the wrong orange wire. That would definitely foul things up.
 
1 - 6 of 6 Posts
Top