Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 4 of 4 Posts

·
Registered
2003 chevy trailblazer_lt_ext
Joined
·
2 Posts
Discussion Starter #1
I recently purchased my 03 Trailblazer EXT 4.2L. The front heat and air did not work from day one. We survived summer with the HVAC 2 and open windows/sunroof. The many posts I have read seem to indicate that the problem is likely a dead blower or blower resistor module or faulty wiring. The blower runs directly off of the battery, so it is fine. I pulled the front console and the climate control and wiring looks good. The ground appears normal. Pretty sure issue is with the blower resistor module. However, with my J2 air, I do not have the more failure-prone resistor frequently reported. I have ordered a new A/C Delco 1580567, but am wondering if it could be anything else. I understand that the actuators are very failure prone and am wondering if they can in any way interfere with the operation of the blower. If the blower works off the battery and the wiring is good, could it be anything else other than the resistor? Fixing this problem can get very expensive very fast!
 

·
Banned
2004 gmc
Joined
·
26,181 Posts
Actuators can not interact with the blower function.

Did you check the voltage going into the blower speed control module? Might be a simple fuse. Front fuse #35.
 

·
Registered
2003 chevy trailblazer_lt_ext
Joined
·
2 Posts
Discussion Starter #3
Fuse 35

Yup. Looks fine. The spiral design is a little unfamiliar, but it looks fine. Could it be anything else? Noticed the heat today, which tells me temp actuator is good. It's just not blowing.:thx
 
1 - 4 of 4 Posts
Top