Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 18 of 18 Posts

· Registered
2004 chevy trailblazer_lt
Joined
·
141 Posts
Discussion Starter · #1 ·
ok fellas well ill tell ya what the problem is i have 2 12' jl w7s and 2 boston acoustic gt-24 2 channel amps 1 4 each sub well i have had them hooked 4 bout 3 weeks worked amazin hit 141.7 on audio controllers any way well yesterday i noticed that when i was wangin lol only 1 sub was hittin so the amp had went to protect mode well then bout 10 seconds later the other went to protect well now the bass will be there 4 couple seconds and then ether both shut off or 1 they will just go to protect mode well i know its not remote wire checked it but i have stnger spv 35 battery and the relay 4 it so please let me know what to do all u audio guroos i cant go with out bass lol thnks in advance thNK
 

· Registered
2004 chevy trailblazer_ls
Joined
·
52 Posts
it could be a couple of things.
1. Check your wiring power/ground.
2. Turn system up n take a volt meter to ur power input on the amp make sure u r getting atleast 11 volts should be twelve, n no more the 13 for ur set up.
If all is good try::m2:
3. Check ur sub wiring make sure u have them wired up to the proper ohms, while making sure ur not running to low of an ohm that the amp cant handle.
 

· Registered
2004 chevy trailblazer_lt
Joined
·
141 Posts
Discussion Starter · #3 ·
THANKS MAN ILL try that in mourning i know im running 13.9 volts i just didnt understand how it caN BE GREAT AND THEN JUST START SHUTTIN OFF thanks keep thoughts comin thanks
 

· Banned
Joined
·
4,337 Posts
did you try the previously mentioned suggestions yet? You will most likely run into at least one of those problems, especially since both amps are doing the same thing. I'd say either voltage problems or wiring are the 2 main issues to check. When you are bumpin, do your lights dim a lot?
 

· Registered
2005 chevy trailblazer_ls
Joined
·
378 Posts
Sounds like a loose ground. Or, and I mean a big or, you accidentally reversed the phase of one of your subs and they are canceling each other out, which will make the amps work harder and in turn put them in to protection mode.

141.7 seems a little quiet for that set up, what is your box size?
 

· Registered
2007 chevy trailblazer_ls
Joined
·
1,222 Posts
I'm almost positive it is the woofer wiring, the amps you mentioned are only stable at 2 ohms and your subwoofers are probably wired lower than that. Your subs are dual 1.5ohms

If you have it wired like this then it's .75 ohms far too low for the amp to handle,




This is how it should be wired,


I know your amps are in protect, but I suggest not trying to bump until you find out the problem, you could cause damage to your subwoofers.

Hope this helps.:yes:
 

· Registered
2004 chevy trailblazer_lt
Joined
·
141 Posts
Discussion Starter · #10 ·
well the lights dont dim at all because of the stinger battery and the volts are good 13.9 but if any 1 didnt know 12' w7s are svc but im gana go try now 2 c what i can do please more ideas if have any
 

· Registered
2007 chevy trailblazer_ls
Joined
·
1,222 Posts
well the lights dont dim at all because of the stinger battery and the volts are good 13.9 but if any 1 didnt know 12' w7s are svc but im gana go try now 2 c what i can do please more ideas if have any
I've seen some 12" w7's that were dvc and they were 3 ohms, if yours are svc then your amp should be seeing 3 ohms. Continue checking all that has been mentioned above.
 

· Registered
2004 chevy trailblazer_lt
Joined
·
141 Posts
Discussion Starter · #15 ·
well guys the reason was the ground had gotton loose so its fixed and the reason i hit that is because i didnt have subwoofers up and i did the db reading yesterday and the amps keept shuting off so i couldnt get a real read so it was ok lol and i need a bigger box thanks 4 all the help every 1:D
 

· Registered
2007 buick rainier
Joined
·
328 Posts
Try using spell check when posting so non texters can read your postings. It's the little ABC above a check mark in the upper right hand corner of the message box.:thx
 
1 - 18 of 18 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top