Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 5 of 5 Posts

·
Registered
2002 gmc envoy_slt
Joined
·
14 Posts
Discussion Starter · #1 ·
I have an '02 Envoy SLT. I have replaced the spark plugs (ac delco iridium) and cleaned the throttle body.
I am still having misfires. I have a bad coil pack on cylinder one (ordered one for replacement) and I am also getting code P0013, B Cam Position Actuator open circuit bank 1. I don't know what this means so i don't know how to troubleshoot it.
Any advice would be greatly appreciated.
 

·
Banned
2004 gmc
Joined
·
26,181 Posts
That code just means the wiring to the Cam Position Actuator has an open or short. Could be a bad unit, or simply an intermittent in the connector to it. Since it sometime seeps oil, a good cleaning and reconnection is the first step.

As for where it is, it's item 421 in this drwg. Passenger side near the front.

 

·
Registered
2004 chevy trailblazer_lt
Joined
·
13 Posts
Pigtail connector

Any ideas on a part number for the pigtail connector to the actuator? The wires on mine have gone bad, but since the part stores don't appear to carry the actuator, none have the cross-reference to the electrical pigtail.
 

·
Registered
2002 chevy trailblazer_ltz
Joined
·
3,250 Posts
Any ideas on a part number for the pigtail connector to the actuator? The wires on mine have gone bad, but since the part stores don't appear to carry the actuator, none have the cross-reference to the electrical pigtail.
Rockauto.com sells the connector plug for the actuator.
 

·
Registered
2004 chevy trailblazer_lt
Joined
·
13 Posts
Thanks. I have them checking to see if the pigtail they offer matches the one I need. I found it under "Camshaft Position Sensor", not with the actuator, but the description indicates its for the actuator. Of course, it was the one part of those listed that didn't have a picture with it....
 
1 - 5 of 5 Posts
Top