Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 7 of 7 Posts

·
Registered
2006 gmc envoy_sle
Joined
·
1 Posts
Discussion Starter #1
Hello All -

I've searched for a few hours to try and fix this issue, but didn't see anything. I have an 06 Envoy and the low beams are always on when the switch is in 'auto' position.

I've tried switching 45 and 46 relays...no change.
All other functions of the switch work properly (lights off, park lamps only, manual headlights on).

I've verified that it's not just the DRL's on - the park lights/tail lights are always on as well when the switch is in 'auto' position.

I'm thinking either the headlight switch or the light sensor in the dash.

Any ideas? Thanks!
 

·
Registered
2006 chevy trailblazer_ls
Joined
·
4,009 Posts
That would be my guess unless....


Do you have anything mounted over the sensor? I have my emergency light mounted on the dash and it toys with the light the sensor gets. Do you have a GPS, radar detector, or anything mounted anywhere near that sensor?


Chris
 

·
Registered
2009 chevy
Joined
·
6,431 Posts
maybe the light sensor on the dash went bad?
That would be my guess unless....
This would be a 3rd agreement :thumbsup:
Do you have anything mounted over the sensor? I have my emergency light mounted on the dash and it toys with the light the sensor gets. Do you have a GPS, radar detector, or anything mounted anywhere near that sensor?
Chris
Or, maybe something tossed onto the sensor.
It's mid dash, near the glass.
 

·
Registered
2005 chevy trailblazer_ls_ext
Joined
·
255 Posts
im having this issue, however with my fog lights, i would turn the truck on and my fogs turn on automatically....pretty irritating
 

·
Registered
2004 chevy trailblazer_lt
Joined
·
1,298 Posts
I'm going to add a fourth agreement for the O/P's problem being the dash
sensor.

Saranykm, there are mainly two points of possible failure for your fog lights.
One is the dash switch, the other is the relay possibly being stuck on. You
can try disconnecting the switch and seeing if the lights shut off. If they
don't, then it's probably a stuck relay. (There is also the possibility of a short
in the wiring, but the switch and relay are the more probable failure points.)

How handy are you with a volt meter?

Good Luck-

Chris
 

·
Registered
2005 chevy trailblazer_ls_ext
Joined
·
255 Posts
the switch works fine. i just push the button and they shut off. i wanted to just finally pull the fuse, and not have them working, but i like the fogs and they look good with the bulbs i installed in there.
ill poke around the relay and volt meter...
 
1 - 7 of 7 Posts
Top