Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 8 of 8 Posts

·
Registered
2002 chevy trailblazer_lt
Joined
·
899 Posts
Discussion Starter · #1 ·
Once again it's me...I was having a slight hum 2 weeks ago on my drivers side wheel, and left it until yesterday when the abs system started acting up and engaging at slow speeds when i was coing to a stop, well on my commute back from work, it engaged once more but this time the abs and brake light came on, no more engaging from the abs, got home replaced the bearing (nice and easy job btw, i was amazed) reconnected the sensor, started the engine and to my dismay the abs light is still on, the brake light is off, but the abs one is still there, i drove around for about 1 hr and did a 60 mile drive, light never went off, went to work this morning, light is still on....any ideas ?

Thanks
 

·
Registered
2002 chevy
Joined
·
2,582 Posts
Once again it's me...I was having a slight hum 2 weeks ago on my drivers side wheel, and left it until yesterday when the abs system started acting up and engaging at slow speeds when i was coing to a stop, well on my commute back from work, it engaged once more but this time the abs and brake light came on, no more engaging from the abs, got home replaced the bearing (nice and easy job btw, i was amazed) reconnected the sensor, started the engine and to my dismay the abs light is still on, the brake light is off, but the abs one is still there, i drove around for about 1 hr and did a 60 mile drive, light never went off, went to work this morning, light is still on....any ideas ?

Thanks
DId you replace one or both bearings? Cause when the dealer replaced my hubs the light turned off.

Use your HPtuner to clear the codes and see if the abs light will pop up again.
 

·
Registered
2002 chevy trailblazer_lt
Joined
·
899 Posts
Discussion Starter · #3 ·
DId you replace one or both bearings? Cause when the dealer replaced my hubs the light turned off.

Use your HPtuner to clear the codes and see if the abs light will pop up again.
I only replaced the faulty bearing (driver side) truck is nice and quiet, but the abs light is still on, When i connect my hptuners i have no errors, well i think it does not talk to the abs system, but i'm not sure
 

·
Registered
2002 chevy
Joined
·
2,582 Posts
I only replaced the faulty bearing (driver side) truck is nice and quiet, but the abs light is still on, When i connect my hptuners i have no errors, well i think it does not talk to the abs system, but i'm not sure
the other hub might be defective. replace it and see what happens.
 

·
Registered
2002 chevy trailblazer_lt
Joined
·
899 Posts
Discussion Starter · #5 ·
problem solved, i checked the conenctor and for an unkown reason the pins within the connectors were "moved" so instead of going in the female pins, they were going on the top holes where there are no connectors

finnaly an issue that was simple and easy to fix
 

·
Registered
2002 chevy
Joined
·
2,582 Posts
thats good news! at least we all know how to solve the ABS light problem thanks to you.
 

·
Registered
2002 chevy trailblazer_lt
Joined
·
899 Posts
Discussion Starter · #7 ·
thats good news! at least we all know how to solve the ABS light problem thanks to you.
I would'nt say this solves most of the problems here on the site, but it is something to consider, on my hand i was already expecting to be told abs controller or pump shot or something like that, nope it should said open circuit on driver side front wheel sensor
 

·
Registered
2002 chevy
Joined
·
2,582 Posts
I would'nt say this solves most of the problems here on the site, but it is something to consider, on my hand i was already expecting to be told abs controller or pump shot or something like that, nope it should said open circuit on driver side front wheel sensor
well at least you got the job done:tiphat
 
1 - 8 of 8 Posts
Top