Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 3 of 3 Posts

·
Registered
2003 chevy trailblazer_lt
Joined
·
25 Posts
Discussion Starter · #1 ·
Guys I know the fan clutch issue has been beat to death but I had another question about it. I have an 03 Trailblazer that for the past year has been ticking at the fan clutch at idle. Well today after towing for 5 hours the check engine light came on. Had a scan at autozone and came up with p1482. Other than the ticking it seems ok like not roaring or staying at the right temp. Is there anything wrong with running it like that with the ticking or should i just bite the bullet and replace it? Also what is the correct part number so when I order online I can make sure I get a new updated one. Thanks in advance.
 

·
Banned
2004 gmc
Joined
·
26,436 Posts
P1482 is an unusual one, indicating a wiring issue more than a fan internal problem. Inspect all the connectors, but you might want to just change it on YOUR timetable instead of away from home on ITS timetable. Just get the latest Dorman unit and you know it will be the latest design. Part numbers are all over those other threads.

You might also get an updated PCM flash from a dealer or independent GM-specialist mechanic with a high end scan tool. That will just make sure you get optimum cooling when you first start up.
 

·
Registered
2003 chevy trailblazer_lt
Joined
·
25 Posts
Discussion Starter · #3 ·
Thanks for the quick reply. I am going to check the wiring to make sure there is no bare spot. I just ran up to the store and it cleared. It has done this before when I towed and then cleared later. After I check the wiring I am going to probally just buy another clutch. I am sick or pulling up somewhere and have the ticking timebomb.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top