Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 20 of 221 Posts

·
Northwest Chapter
Joined
·
11,824 Posts
Discussion Starter #1
Hey guys, just trying to figure out who lives in the Pacific NW! I know of a few guys but I know there are others out there who dont post a lot. Just say hi, or some random thought or what you are currently doing besides being on TrailVoy. Anything, I just want to know who's out there!!

Thanks everyone,
Erik
 

·
Northwest Chapter
Joined
·
11,824 Posts
Discussion Starter #5
I should still be down for that, Ill know for sure here in week or so.

But back on topic, anyone else in the great NW that wants to just post up and say hi? If not Ill go mad, there are TONS of our rides everywhere around here. Geez I see like 4+ a day.
 

·
Registered
2004 chevy trailblazer_ls
Joined
·
1,574 Posts
I'm with Erik. I see a minimum of 10 Trailvoys a day. Theres gotta be some more members from the NW. Just give a hello or something.
 

·
Northwest Chapter
Joined
·
11,824 Posts
Discussion Starter #8
This is Eric from Kent. Currently troubleshooting the accursed p0300 on my TB.
2002 TB LT.
Welcome man! Another member, and with a good name to boot!

P0300 is a random misfire correct? Have you tried swapping coil packs around? New spark plugs?
 

·
Registered
2002 chevy trailblazer_lt
Joined
·
17 Posts
Welcome man! Another member, and with a good name to boot!

P0300 is a random misfire correct? Have you tried swapping coil packs around? New spark plugs?
That's correct. Here's the story from another thread:

Started with mild miss - showed code P0304 (cylinder 4 misfire).

I replaced the plug in number 4 cylinder, then swapped the coil pack between 2 and 4. I detected no moisture problem nor residue in the number 4 spark plug cavity. I then got P0300 (multiple random misfires).

I swapped coil packs back to original positions, still code P0300.

Since I'd bought the plugs, I changed them all out. I could detect no carbon tracking on any of the coil boots. The only thing I did notice was that the coil packs seemed to have a bit more "spring" when I removed them. That is, they rose a bit when I loosed the bolt - much more than when I replaced them. The plugs are the same size, though they are NGK platinums rather than AC Delco. I was careful to ensure that the boots were landing on the plugs. Still very noticeable misfiring both at idle and under load and reading code P0300.

I pulled the throttle body and cleaned it with TB cleaner. I disconnected the battery overnight. Still getting a noticeable miss, but not as bad as before. Took it for a drive and it seemed to perform much better when under load, but still has a noticeable misfire at idle. Still getting P0300 code.

Pulled the MAF sensor and cleaned it. No change.

It seems to run fine at start up, but begins to miss after 30 seconds or so.

Royal PITA. I'm going down to NAPA today to pick up a spark tester. I'm still thinking it's a bad coil pack but I'm not going to buy one until I know for sure. I also don't want to pull the fuel rail until I've tried everything else. This isn't the best weather for working on the car outside...
 

·
Northwest Chapter
Joined
·
11,824 Posts
Discussion Starter #10
Hmm, well Im going to move this to PMs to keep this thread on topic. But Eric, Ill be out of town from Monday thru Sunday but then next Monday-Wednesday Im free to come take a look at your TB if you want.
 

·
Registered
2005 chevy trailblazer_ls
Joined
·
916 Posts
Wow! all but one so far are from Seattle and/or Spokane. My home base is in Sherwood, OR. I'm temporarily living in Dubai UAE. Expect to be here until at least 2010, maybe 2012. I use to drive from Linclon City to Monmouth, OR two or three days a week through the Coast Range logging roads in a '88 S-10 Blazer. A lot more fun than driving the tarmac!
 

·
Registered
2007 chevy trailblazer_ss_1ss
Joined
·
4 Posts
hi erik. i was at the original tbss meet in issaquah at xxx. ive done some modding since then.
 

·
Northwest Chapter
Joined
·
11,824 Posts
Discussion Starter #13
Wow! all but one so far are from Seattle and/or Spokane. My home base is in Sherwood, OR. I'm temporarily living in Dubai UAE. Expect to be here until at least 2010, maybe 2012. I use to drive from Linclon City to Monmouth, OR two or three days a week through the Coast Range logging roads in a '88 S-10 Blazer. A lot more fun than driving the tarmac!
Well welcome to the site anyway! Even if you're over in the UAE you're from here, and that counts!

hi erik. i was at the original tbss meet in issaquah at xxx. ive done some modding since then.
Yep, I remember ya duff! Cant wait to see the mods, have to come to the next SS meet and bum a ride!:cool:
 

·
Registered
2006 saab 9_7x
Joined
·
13 Posts
New (to me) 9-7x owner here in Beaverton, OR. I've had mine for about a week and havn't seen another on the road in that amount of time.

oh, I mean.... Hi :raspberry
 

·
Northwest Chapter
Joined
·
11,824 Posts
Discussion Starter #17
Glad to see some more people are posting up in here, we've got a few big changes coming up in the next few weeks/months and I want as many people from the NW to be a part of it!

My TBs not big, its dropped but Im pretty sure I open my mouth more than anyone else on here from the NW (as bad as that sounds...:x).
 

·
Registered
2006 chevy trailblazer_ls
Joined
·
72 Posts
I see that. Your ride looks good. I went a diff route. I have 2 in maxx stack lift pucks and toyo open countyr at's Im actually looking to go bigger. The pic on my prof is old. Im waiting for my brush guard to get here before i post more pics. I just got done with my sub/amp install, nerf bars, vent visors and am working on light bar, exhaust, brush guard etc.
 

·
Northwest Chapter
Joined
·
11,824 Posts
Discussion Starter #19
Well Im looking to get a new car this summer/fall hopefully and if my parents want to keep the TB Ill get at least some stock coilover assemblies from the junkyard and use those in the winter, maybe even buy the BDS kit and some Tahoe springs for the rear.

You should come to our meet on Jan 24-25th man! Thats an invite for anyone who wants to drive to Leavenworth, WA for either a day meet or spend the night! Check out the thread for "Summer 08 turned Winter 08/09 meet" thread!
 

·
Registered
2006 chevy trailblazer_ls
Joined
·
72 Posts
Yeah im really thinking about comming. Not sure which day as ill be in yakima to pick up new sub and brush guard from my parents but if anything ill just drive over blewit and through wenatch if they ever open it.
 
1 - 20 of 221 Posts
Top