Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 17 of 17 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
So today I shut my trailblazer off and when I opened the door to get out I noticed the radio was still playing. So I started the truck again and tried to shut it off and the same thing happened. Then I noticed that the gauges were still lit up and the little symbol off the battery on the gauge cluster is staying on, kinda like if the key was turned forward. I tried undoing the battery and hooking it back up and nothing happened. Anybody have any ideas for me??
 

·
Registered
2003 chevy trailblazer_ls
Joined
·
75 Posts
I may have the same problem.....

The stereo on mine stays on for about 5 seconds and the lights stay on for 10 to 15 seconds after I take the key out of the ignition. :confused:

Any help is greatly appreciated. :)
 

·
Western Canada Chapter
2003
Joined
·
6,411 Posts
Sounds like a bad ingnition switch.

Can you pull the key out in any other position than "off"?
Is your transmision lock working?
Can you turn it off and pull the key out while it's still in Drive?
 

·
Banned
2004 gmc envoy_sle
Joined
·
728 Posts
I AGREE W/ Blazernut yet again,sounds like a bad ingnition switch, you might want to send a pm to Envoyboy05 I know from the other thread he stated he works at a dealer, and should be able to get a good price for you.
 

·
Registered
2002 chevy trailblazer_lt
Joined
·
4,839 Posts
The stereo on mine stays on for about 5 seconds and the lights stay on for 10 to 15 seconds after I take the key out of the ignition. :confused:

Any help is greatly appreciated. :)
yours is normal; after pulling the key out your radio and lights should stay on until you open your door or the amount of time you metioned lapses.

the other issue is most likely related to a bad ignition like stated previously.
 

·
Registered
2004 gmc envoy_slt_xl
Joined
·
1,356 Posts
Mine just wont shut off period. Its been like two hours and it is still on???!!! Any help?
IT doe ssound liek the swithc, but could jsut be some dirt or gum .. try blowing some WD-40 (tiny amount) in teh key slot .. then work the key in and out back and forth .. then shoot some compress air in there .. like from an air can .. I remember a lock smith telling me that trick some time ago, so when i had to try it it worked great.
 

·
Registered
2003 chevy trailblazer_lt_ext
Joined
·
48 Posts
I've had weird electrical problems lately ... once the overhead lights would not come on by pushing them, then they worked the next time I started my TB, but the radio and CD player had no audio at all. The radio worked fine the next time I started up my TB, but then the memory seat buttons didn't work! Weird!! Plus, it seems as though sometimes the air conditioner (compressor) won't kick in when I use the automatic starter. Then I'll go two or three weeks with no problems at all! Still love it though, just hope these minor problems aren't going to lead to something worse.
 

·
Registered
Joined
·
7 Posts
similar issues

When the tb is off and key removed the service engine soon light stays on and same with the compass in the mirror. Let sit for a day and a half and now it won't even start with a jump. What the heck is wrong Im lost.
 

·
Banned
2003 gmc envoy_slt
Joined
·
7,190 Posts
:eek:fftopic: I wonder if the software in these computers was developed by Bill Gates? :undecided It's like an early form of Windows operating system. Only, instead of the "Blue Screen Of Death", you get all kinds of electrical screw-ups. So many of these problems ( But unfortunatly, not all) are fixed just by disconnecting the battery for 30 or 40 minutes. :m2:
 

·
Registered
Joined
·
7 Posts
Crap

Just found out that my Power Control Module may be shot. My TB would not start. After testing some other fuses and relays, and everything checking out. I pulled the fuse to the PCM and the put it back in. And wouldn't you know the stupid thing started right up. How do I find out if the PCM is bad or not? Oh and how much would it be to replace it if it is shot?
 

·
Registered
2009 chevy
Joined
·
6,431 Posts
Just found out that my Power Control Module may be shot. My TB would not start. After testing some other fuses and relays, and everything checking out. I pulled the fuse to the PCM and the put it back in. And wouldn't you know the stupid thing started right up. How do I find out if the PCM is bad or not? Oh and how much would it be to replace it if it is shot?
The PCM very seldom fails. Spend $20 on an ignition switch. That will probably cure the problem.
If changing the switch doesn't fix it, report back, we can probably help.
 

·
Registered
Joined
·
34 Posts
When the tb is off and key removed the service engine soon light stays on and same with the compass in the mirror. Let sit for a day and a half and now it won't even start with a jump. What the heck is wrong Im lost.
Wow mine is doing this right now!! I disconnected the battery for now till I figure WTF is going on!! anybody else have this??? also right now if I start it and take the key out it stays F&^$ing running... I'm so tired of the SS! :(
 

·
Registered
Joined
·
34 Posts
Change the $20 ignition switch. Run a search for pictures and how to's.
Thanks for the reply by I did that with no luck and I took the old one apart and looked at it, it actually looks like its in great shape (very clean no burns) I guess I have no choice I hate the dealer but its gotta go, oh well. :(
 

·
Registered
Joined
·
3 Posts
I know this is an older thread but I am having same issue with my 04 TB. I have changed the ignition swith and the cylinder. I had yto put a kill switch by battery, the only other thing I can thionk of is the release pin/button at the base of stweering column. Ya know the one ya gotta push to release keys? What is that bugger called? Could that be it, cause I don't havbe to push that to get key out, never did! Bought Tammy Trailblazer used and she has had a parasitic drain since I got her. Lights, radio, all electric stuff stay on even with no key! Please help me
 

·
Premium Member
'05 Chevy TB EXT
Joined
·
4,647 Posts
I know this is an older thread but I am having same issue with my 04 TB. I have changed the ignition swith and the cylinder. I had yto put a kill switch by battery, the only other thing I can thionk of is the release pin/button at the base of stweering column. Ya know the one ya gotta push to release keys? What is that bugger called? Could that be it, cause I don't havbe to push that to get key out, never did! Bought Tammy Trailblazer used and she has had a parasitic drain since I got her. Lights, radio, all electric stuff stay on even with no key! Please help me
Again, Josie --- you are now triple posted over your problem ..................................

GO BACK TO YOUR ORIGINAL POST TO GET THE ANSWERS YOU NEED ---

DO NOT PILE ONTO SOMEONE ELSE'S POST!


VERY BAD ROBOT!
 
1 - 17 of 17 Posts
Top