Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hi all

I have a problem with my 2004 envoy v6 4.2 ..

When starting the engine in the morning then turning on the AC.. the compressor is starting for about 2-4 seconds then it stops for 2 seconds then it start again and the same story continues until I drive the car.. even after driving the temp of the blowed air is not cold enough compared to my other 2006 envoy.
And the same problem appears again after I stop the engine for more than one hour.

Note that I've checked the system pressure and every thing is OK ??

Please Help Me..

With Best Regards ..
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
I've Already checked the gas.. There is no leak :(

On the other hand, when the car is moving the AC works fine even if the car stopped (But the engine is working)..

the problem appears after starting the car when the engine is cold or semi cold.
 

·
Registered
2003 gmc envoy_slt_xl
Joined
·
270 Posts
check the copressor pully or belts, by the way do you have AC filter?

Assalam Alaykom,
Every AC system has what you called a filter. It's technical term is the orifice.
Yes. If it's clogged you get this kind of problem, but mostly it's either not enough gas or oil in the pipes and AC radiator.


Hi all

I have a problem with my 2004 envoy v6 4.2 ..

When starting the engine in the morning then turning on the AC.. the compressor is starting for about 2-4 seconds then it stops for 2 seconds then it start again and the same story continues until I drive the car.. even after driving the temp of the blowed air is not cold enough compared to my other 2006 envoy.
And the same problem appears again after I stop the engine for more than one hour.

Note that I've checked the system pressure and every thing is OK ??

Please Help Me..

With Best Regards ..
Assalam Alaykom,
Have you done any repairs on the AC system before? If yes, When?
If no, What's the mileage on your truck?
Can you see oil remains on the any of the AC pipes or the compressor at the clutch side?
 

·
Registered
2002 chevy trailblazer_ltz
Joined
·
172 Posts
I had the same problem after I got my compressor replaced last year. The pressure was just the smallest bit over spec. When on, the pressure would build until the safety mechanism would turn it off to let it go down, then on again until it would build, then shut of, etc...

The fix was to vacuum all the coolant from the system, let the car rest for 30 minutes, then fill exactly to spec. I haven't had a problem with it since.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #8 ·
Assalam Alaykom,
Have you done any repairs on the AC system before? If yes, When?
If no, What's the mileage on your truck?
Can you see oil remains on the any of the AC pipes or the compressor at the clutch side?
Wa alaykom al salaam,
Dear sir I haven't done any repair on the AC system except the refill of the AC gas.
Mileage = 92000 km
There is no remain oil or dirts on any AC pipe neither the compressor.


I had the same problem after I got my compressor replaced last year. The pressure was just the smallest bit over spec. When on, the pressure would build until the safety mechanism would turn it off to let it go down, then on again until it would build, then shut of, etc...

The fix was to vacuum all the coolant from the system, let the car rest for 30 minutes, then fill exactly to spec. I haven't had a problem with it since.
Thank you Mr mtritt,
What is other members opinion over this solution ?
 

·
Registered
2003 gmc envoy_slt_xl
Joined
·
270 Posts
I support mtritt's idea, but make sure that they install the original American gas. They always use the cheap Chinese gas. It would be a better idea to buy your own gas cylinder to make sure you won't be cheated. On the long run, it's cheaper.
 

·
Registered
2007 chevy trailblazer_lt
Joined
·
260 Posts
Asslam Alaikum,
How much did it cost you to replace because i am also facing the same problem.
 
1 - 16 of 16 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top