Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 5 of 5 Posts

·
Registered
2004 gmc envoy_slt
Joined
·
199 Posts
Discussion Starter #1
So I've been searching through, reading a bunch of posts about AC issues, but still can't figure this one out.

My problem is that the blowers don't seem to be working as well as they used to out of the front vents. When I have it set to just the dash vents, there is air coming out of the floor vents as well, and when I have it set to both dash and floor, it's all coming out of the floor vents at 100%. Now here's the interesting part, if I turn the AC to OFF, air is STILL coming out of the floor vents.

Is this the dreaded dead actuator issue I've been reading about? I'm about to go pull the HVAC fuse for 2 minutes and put it back and let the system reset, I'll post back with how it goes.
 

·
Registered
2004 gmc envoy_slt
Joined
·
199 Posts
Discussion Starter #2
Well I tried to reset it, but when I turned it back to RUN, it didn't go through the cycles. Should it be in RUN the whole time, or only when I've put the fuse back in? (Didn't have the keys in when I took the fuse out, don't know if that makes a difference)
 

·
Registered
2004 gmc envoy_slt
Joined
·
199 Posts
Discussion Starter #4
Pulled the 30A fuse that said HVAC, there's a 10A that's listed as HVAC1, should I pull that one as well?
 

·
Registered
2004 gmc envoy_slt
Joined
·
199 Posts
Discussion Starter #5
Fixed. Needed to pull the HVAC B fuse. Reset and works now.
 
1 - 5 of 5 Posts
Top