Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 7 of 7 Posts

·
Registered
2006 chevy trailblazer_ls
Joined
·
2 Posts
Discussion Starter · #1 ·
I changed both wheel bearing hub assemblies and CV half shafts on my 2006 trailblazer. Everything went together as expected. When I started the engine, the ABS light, the Stabilitrak service light and Stabilitrak indicator light stay on. I verified that both connectors plugs were plugged in correctly. Anybody have any insight towards this situation? Any tricks on identifying which side the issue is on?

Thank You
 

·
Registered
2007 chevy trailblazer_ls
Joined
·
67 Posts
re

I have the same issue but no maintenance was performed on my 2007. The lights are off and both will illuminate if I go around a curve real hard.
Any ideas??? Oh and Hi by the way, my first post!
Can I read codes to find the problem?
 

·
Registered
2006 chevy trailblazer_ls
Joined
·
2 Posts
Discussion Starter · #3 ·
Light Out

I found one of the wheel speed sensors failed in a brand new hub assembly. I would make sure that both speed sensors work.
 

·
Registered
2007 chevy trailblazer_ls
Joined
·
1,239 Posts
I had the same problem. Replaced the steering wheel postion sensor and that fixed it.
 

·
Registered
2007 chevy trailblazer_ls
Joined
·
67 Posts
steering position sensor

I'm seeing what you are saying 07TB.
Last week I turned the steering wheel left and right before I put it into gear. It tripped the light immediately. It tends to do this always when it rains out, almost never when it is dry.
Any further troubleshooting?
Where is the sensor located?
high dollar?
Thanks TJ
 

·
Registered
2007 chevy trailblazer_ls
Joined
·
1,239 Posts
I'm seeing what you are saying 07TB.
Last week I turned the steering wheel left and right before I put it into gear. It tripped the light immediately. It tends to do this always when it rains out, almost never when it is dry.
Any further troubleshooting?
Where is the sensor located?
high dollar?
Thanks TJ
The sensor lists for about $85 and takes about 45 minutes to change.

See here:
http://forums.trailvoy.com/showthread.php?t=82459
 

·
Registered
2006 chevy trailblazer_ls_ext
Joined
·
21 Posts
StabiltiTrac-Light On randomly???

I have an 06 Trailblazer EXT LS that I just paid $60 to be put on a Diagnostic machine that Found Codes: CO455, C0131 & C0244. They put Diag Grease in Connection of Electronic Brake Control saying Module/Possible Bad Connection... If Problem Persists may need to Replace EBCM... But I was wondering in 2010 I was in a bad wreck hit a woman in a Grand Prix with dark tail lights, brake, and turn signal in rear... At the last second to try to keep air bags from deploying I swiveled hit her with driver side corner of SUV braking out her rear window even causing damage to left front finder light and turn signal housing... Could this impact caused damage to the Wheel Speed Sensor and it is just now showing an issue??? Also have noticed that every time I am in a parking lot somewhere that when I cut front tires hard they want to squeal.... What do you that should I get the Wheel Speed Sensor and pay someone to install since I am disabled due to two failed back surgeries and have a Stimulator implanted for pain but still don't get much relieve especially when I try to do very much...... Thank very very much......
 
1 - 7 of 7 Posts
Top