Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 7 of 7 Posts

· Registered
2005 chevy trailblazer_lt_ext
Joined
·
51 Posts
Discussion Starter · #1 ·
I filled up with gas, I was driving early Sunday morning out in the Saskatchewan outback I was getting low on gas, my low fuel light came on just as I pulled up to the pump, after I filled up the light was still on and the gas gauge was below "E" the CIT showed -------- a fews seconds went by and the gauge went up to full, during the 400 Kms home the gauge went down to below "E" several times, I filled up with gas again and then the Low power light came on (the yellow one that looks like an engine) and its staying on, the gas gauge is only working 50% of the time. I am going to try and have it looked at tommorow but I really would like know what is going on.:(
 

· Registered
2004 chevy trailblazer_ls
Joined
·
694 Posts
I filled up with gas, I was driving early Sunday morning out in the Saskatchewan outback I was getting low on gas, my low fuel light came on just as I pulled up to the pump, after I filled up the light was still on and the gas gauge was below "E" the CIT showed -------- a fews seconds went by and the gauge went up to full, during the 400 Kms home the gauge went down to below "E" several times, I filled up with gas again and then the Low power light came on (the yellow one that looks like an engine) and its staying on, the gas gauge is only working 50% of the time. I am going to try and have it looked at tommorow but I really would like know what is going on.:(
Clogged fuel line, Bad gas, Faulty Gas level IN-TANK gauge.:m2:
 

· Western Canada Chapter
2003
Joined
·
6,421 Posts
I filled up with gas, I was driving early Sunday morning out in the Saskatchewan outback I was getting low on gas, my low fuel light came on just as I pulled up to the pump, after I filled up the light was still on and the gas gauge was below "E" the CIT showed -------- a fews seconds went by and the gauge went up to full, during the 400 Kms home the gauge went down to below "E" several times, I filled up with gas again and then the Low power light came on (the yellow one that looks like an engine) and its staying on, the gas gauge is only working 50% of the time. I am going to try and have it looked at tommorow but I really would like know what is going on.:(
Sounds like the sending unit. A real PITA as you have to drop the tank as it is part of the assembly located on top of the tank. Try a can of Seafoam in the tank first :m2:
 

· Registered
2005 chevy trailblazer_lt_ext
Joined
·
51 Posts
Discussion Starter · #6 ·
I drove 300 Kms this weekend to the lake and back, about 50 Kms. out the gauge went back to normal and all has been fine since. That was the first time I have ever been low enough on gas to have the light come on, must have been stuck or dirty or something. I only have 8 mons. of warrenty left so if it craters I hope its soon!
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top