Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 8 of 8 Posts

· Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
04 tb ls, manual dual climate control. Last year the air was not blowing cool so I hooked up guages and had some extremely high pressures, thought freon was low but found out I need the fan/clutch/ electric combo. Winter came and I forgot about it. Now my problem is similar to the other listed but a little different. The passenger side is blowing cold but the drivers side is warmer, why couldn't it be the other way LOL. I took the actuator out to see if there was any issue with the door itself but the door seems to be moving fine with no binding. I put the door all of the way to cold and eliminated the actuator to see if it would blow cold and it did NOT. So it looks like the actuator is good now what? It does change temp from hot to cold on passenger side and drivers side heat is great but just not cold enough. I plan on replacing the fan clutch tomorrow but any ideas on the A/C?
Thanks in advance
brains
 

· Registered
Joined
·
11 Posts
Discussion Starter · #5 ·
I evacuated the system, replaced the orifice tube, and recharged to the proper amount. The only fan that was running was the clutch, not the electric portion of it. Usually when the a/c comes on shouldn't the fan kick on? If not you could also get high pressures. I had a scan tool hooked up and the fan was demanded on but not working. This is why I think the fan is one problem. As far as the warm air out of the drivers vent, even though the blend door is moving what could cause this. As I stated earlier I removed the actuator and still had warm air while the blend door was in the full cold position.
Thanks
 

· Registered
Joined
·
11 Posts
Discussion Starter · #7 ·
It is an I6. I was under the impression that the fan is a elctroviscous type. Shouldn't it run a little faster with the air on? If not then the fan is good. What about the blend door?
 

· Registered
Joined
·
11 Posts
Just talked to a guy at the dealer and he said that sometimes if the air is a little warmer on the drivers side then the 134 could be a little low. Last time I checked was last year, I just have not had time to look at it this year and of course it is HOT now. Hopefully I will have time tonight to hook up guages and see whats up.

I also just picked up a new clutch. I remember last year I had a shop look at is and they noticed that the fan was just free wheeling and not moving enough air. They put a fan in front of it and it got much cooler and the guage pressures dropped to normal
 

· Registered
Joined
·
11 Posts
Discussion Starter · #13 ·
Well I am finished and what a difference. First it is easier to remove the fan blade from the clutch assembly and then remove the clutch and then the fan and shroud. I replaced the clutch d/t high a/c pressure last year but did not want to pay the $. So today I replaced the fan clutch and then found that the charge was a little low, couldn't tell before b/c the fan was not working properly. I had a new problem that started with warmer air on the drivers side and cooler on the passenger. A guy at the dealer said it was just because it was low in 134. I put in about 1.5lbs and it has never been better. The fan at start up let out a roar but came down, this is how the old blazers used to be. I now have the temp down to 53f, but it is only 75 degrees now we will see tomorrow when it hit 85-90.
Thanks for all of your advice, now on to the next problem.
 

· Registered
Joined
·
11 Posts
Discussion Starter · #16 ·
If you can stop the fan that is bad. I had never heard the fan roar on start up like this new one does. I got mine from napa for 196.00. A/C is still cold on both sides and the fan sounds good. I would do it.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top