Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 7 of 7 Posts

·
Registered
2006 gmc envoy_sle
Joined
·
133 Posts
Discussion Starter #1
Hello, i have a 2006 GMC ENVOY sle 4.2 with manual a/c controls.

while driving hit a bump ( i think ) and a/c kicked off and never cam back on .
isuues
1. a/c system will not come on . no light for the recirc. , a/c and rear defrost . ( i know the rear defrost isn't the same system)

so i just had time to start to look into it, checked all the fusses and relays . all are working jumped the a/c compressor from the low pressure switch and the relay under the hood #44 i think. the relay made it engage but the low pressure switch did not . so i checked to see if three was any power to the LpS and there was nothing . so i think i have it narrowed down to a electrical problem either a connector or a broke wire ( i hope). if someone can post a wiring diagram for this vehicle i can trace it out fully. and any other comments or suggestions let me know please.
 

·
Registered
2004 chevy trailblazer_ls
Joined
·
288 Posts
There's a high pressure switch on the A/C lines near the compressor. Check the wires to that. If you have access to a Tech 2, it will give you all the info you need as to what's wrong. Chased an A/C problem for months, and it turned out the high pressure switch was intermittent, there were corroded wires inside the insulation. Drove me nuts the A/C was intermittent. Soon as I hooked up the Tech 2, it showed the switch was out of range.
Had to get a new switch and connector, works well now.
The problem presented itself the same way as yours, jump the low pressure switch and the compressor wouldn't engage, all the switches and relays were good, knew I had a full charge of freon in the system.
 

·
Registered
2006 gmc envoy_sle
Joined
·
133 Posts
Discussion Starter #3
There's a high pressure switch on the A/C lines near the compressor. Check the wires to that. If you have access to a Tech 2, it will give you all the info you need as to what's wrong. Chased an A/C problem for months, and it turned out the high pressure switch was intermittent, there were corroded wires inside the insulation. Drove me nuts the A/C was intermittent. Soon as I hooked up the Tech 2, it showed the switch was out of range.
Had to get a new switch and connector, works well now.
The problem presented itself the same way as yours, jump the low pressure switch and the compressor wouldn't engage, all the switches and relays were good, knew I had a full charge of freon in the system.
Thanks will check the high pressure switch , don’t have any way to get that scanner but thanks for the info
 

·
Registered
2006 gmc envoy_sle
Joined
·
133 Posts
Discussion Starter #7
Hello, i have a 2006 GMC ENVOY sle 4.2 with manual a/c controls.

while driving hit a bump ( i think ) and a/c kicked off and never cam back on .
isuues
1. a/c system will not come on . no light for the recirc. , a/c and rear defrost . ( i know the rear defrost isn't the same system)

so i just had time to start to look into it, checked all the fusses and relays . all are working jumped the a/c compressor from the low pressure switch and the relay under the hood #44 i think. the relay made it engage but the low pressure switch did not . so i checked to see if three was any power to the LpS and there was nothing . so i think i have it narrowed down to a electrical problem either a connector or a broke wire ( i hope). if someone can post a wiring diagram for this vehicle i can trace it out fully. and any other comments or suggestions let me know please.
Hello, i have a 2006 GMC ENVOY sle 4.2 with manual a/c controls.

while driving hit a bump ( i think ) and a/c kicked off and never cam back on .
isuues
1. a/c system will not come on . no light for the recirc. , a/c and rear defrost . ( i know the rear defrost isn't the same system)

so i just had time to start to look into it, checked all the fusses and relays . all are working jumped the a/c compressor from the low pressure switch and the relay under the hood #44 i think. the relay made it engage but the low pressure switch did not . so i checked to see if three was any power to the LpS and there was nothing . so i think i have it narrowed down to a electrical problem either a connector or a broke wire ( i hope). if someone can post a wiring diagram for this vehicle i can trace it out fully. and any other comments or suggestions let me know please.
Hello, i have a 2006 GMC ENVOY sle 4.2 with manual a/c controls.

while driving hit a bump ( i think ) and a/c kicked off and never cam back on .
isuues
1. a/c system will not come on . no light for the recirc. , a/c and rear defrost . ( i know the rear defrost isn't the same system)

so i just had time to start to look into it, checked all the fusses and relays . all are working jumped the a/c compressor from the low pressure switch and the relay under the hood #44 i think. the relay made it engage but the low pressure switch did not . so i checked to see if three was any power to the LpS and there was nothing . so i think i have it narrowed down to a electrical problem either a connector or a broke wire ( i hope). if someone can post a wiring diagram for this vehicle i can trace it out fully. and any other comments or suggestions let me know please.

okay fixed there was a wire cut in the back center leading to the controls it was an orange wire if I can figure how to put pictures I will
 
1 - 7 of 7 Posts
Top