Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 2 of 2 Posts

·
Registered
2002 gmc envoy_slt_xl
Joined
·
11 Posts
Discussion Starter #1
Hi,

I'm woring on my '02 Envoy XL 4.2 4x4. I am having that squeaking noise at low to medium speeds when the truck is hot. I was told that the seal on the CV axle was worn, and needed replacement.

I went to GM, got the part, took it all apart only to find that they gave me the wrong part! No problem, though as I didn't remove the old seal before checking.

Here's my concern / question:

1) The bearing inside the 1/2 shaft seems dry, no gear oil. I must assume that this is a greased bearing and should not have oil in there. Can anyone confirm?

2) Should I be changing the bearing? Is this hard to do? I think I would need to take out the 1/2 shaft, and the Haynes book insists on a slide hammer.

3) When removing the CV axle, I found a small steel ring inside the spline shaft. It is definately not the snap ring for the axle, and is a bit smaller in diameter than the spline shaft itself. I re-installed it, but I can't find any reference to it anywhere and was wondering if this is an indication of a failed part, or if this is a sort of shim.

Any ideas or suggestions? Has anyone had the squealing noise and replaced the seal to resolve the issue, or taken out the 1/2 shaft? Any tips would be appreciated.

Crang
 

·
Registered
2004 chevy trailblazer_ls_ext
Joined
·
5 Posts
i was going to do this job also but found out it was a wheel bearing. from what i've checked out so far the bearings inside are just greased but as for replacing them i didn't do it. the chevy dealership told me that as long as i had some mechanical skills i should be ok. please if you do the job of replacing the bearing let me know how it worked out. i purchased the bearings and seal to do the job but as i said i didn't need to do it. good luck.
 
1 - 2 of 2 Posts
Top