Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 5 of 5 Posts

·
Registered
2004 chevy trailblazer_lt_ext
Joined
·
5 Posts
Discussion Starter #1
my 4x4 light is on i have not taken it to the dealer for the cost, but i had a guy tell me that there is a wire to deal with the 4x4 and the blower motor and thats why mine only works on high and my 4x4 does not work. is there truth to this or is that guy a total idiot like i believe him to be?:bonk::bonk::thx:thx
 

·
Registered
2004 gmc envoy_slt
Joined
·
2,468 Posts
The guy is full of crap, there is no one wire that is common to both systems.

Do you have the digital HVAC system, the one with two knobs? Or do you have the one with the two sliders for temperature? I think the LT model came with the digital. It's unusual for the digital system to fail with only the high fan speed working, this more normal failure of the manual system.

As for the 4X4 failure, we need more information, like are the lights on the selector switch working at all, and if so, do the lights go steady on at the selected mode? When switching from 2HI to 4HI, do you hear two distinct motor sounds coming from under the truck? Has the transfer case fluid ever been changed?
 

·
Registered
2004 chevy trailblazer_lt_ext
Joined
·
5 Posts
Discussion Starter #3
It is the manual levers for the heat or cool temp. what could be the cause for the high speed only? and the 4x4 has no sounds that i can hear, the lights work on the inside switch if i turn it before the service 4x4 light comes on other then that it stays on awd but is only in 2wd. the pervious owner said they replaced an actuator twice, but didnt tell me which one.:thx:thx:thx:thx:thx
 

·
Registered
2008 gmc envoy_slt
Joined
·
59 Posts
It is the manual levers for the heat or cool temp. what could be the cause for the high speed only? and the 4x4 has no sounds that i can hear, the lights work on the inside switch if i turn it before the service 4x4 light comes on other then that it stays on awd but is only in 2wd. the pervious owner said they replaced an actuator twice, but didnt tell me which one.:thx:thx:thx:thx:thx
Resistor pack needs replaced.

http://forums.trailvoy.com/showthread.php?t=32751
 
1 - 5 of 5 Posts
Top