Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 7 of 7 Posts

·
Registered
2003 chevy trailblazer_ls
Joined
·
2 Posts
Discussion Starter #1
I see that this is a much talked about topic: 4WD Service light on

I have a 2003 4.2L v6 trailblazer.

When I switch 4 wheel drive switch to anything other than 2Hi the 4WD Service light comes on. I can also tell that the 4 wheel drive isn't engaged from how it feels when I turn the car in tight radius. Common problem, I know.

So I tried all of these:
1) pulled fuse #8 (front box) and #45 (rear seat box) fuses for a minute.
2) disconnected the battery completely for 15 minutes
3) replaced front axle actuator

Turning the 4wd switch: 2hi to A4wd I get a lower whirring sound, A4wd to 4hi I get a quicker whirring sound, 4hi to 4lo I get no sounds. (The mode lights turn on and off normally as I change mode.) I do NOT hear the "cluck" sound some people talk about.

Possible causes: I jumped someones car and a couple weeks later my battery went dead. I replaced the battery in my car and all works fine except the 4wd.

I'm thinking I need to do one of the following. Which do you think I should do? Is there an inexpensive way to do it? Are there any other tests I can perform to narrow this down?:

a) replace the Transfer Case Shift motor.

b) flash/reprogram the 4wd system

c) replace the encoder motor.

d) replace connectors and wires between various 4wd systems.

... or if you have another idea for my next step please feel free to mention it.

I am a DIY'er, mechanically minded, I know a little about cars, but I'm not a true car guys.

Thanks!
 

·
Banned
2004 gmc envoy_sle_xl
Joined
·
1,239 Posts
When switching between 2HI and 4HI you should two distinct motor sounds, one is the TC encoder and the other is the front splined disconnect motor. If you hear only one, determine which one is silent and start your troubleshooting there. The Service 4WD light is illuminated when the TCCM (Transfer Case Control Module) does not see the correct feedback from the encoder or the actuator.

Suggest you post your problem at G M T N a t i o n . c o m / f o r u m s (no spaces), most of the experts from here went there long ago.
 

·
Registered
2005 chevy trailblazer_ls_ext
Joined
·
2 Posts
from what you have described and have already done, I would replace the transfer case motor ( Encoder motor ) , without actually touching your rig I would almost guarantee this to be your problem.
 

·
Registered
non_gmt360 trailblazer_lt_ext
Joined
·
241 Posts
+1 for freddyboy! That's where everyone who's anyone is :D

Sent from DROID RAZR MAXX HD
 
1 - 7 of 7 Posts
Top