Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 2 of 2 Posts

·
Registered
2005 TrailBlazer
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi. I'm new to this site and hoping someone here may be able to help with my 4wd problem. I have 05 trailblazer. About a week ago my service 4wd light came on. Shortly after all the lights on my 4wd switch went out and my rig was stuck in 2wd. I had the codes checked and the mechanic told me the codes led him to believe it was the transfer case encoder motor. I got at the wrecking yard and installed it. To my excitement, everything worked. Service light went out, lights on switch lit up and it shifted between front and rear wheel drive smoothly. My excitement was short lived. 15 mins later the service light came on and lights on the switch went out and it won't shift between two and four wheel drive. I pulled the #8 and 48 fuse but got nothing. Any help would be very much appreciated. Thanks
 

·
Registered
2002 chevy trailblazer_lt
Joined
·
1,685 Posts
There is a sensor inside these transfer case shift motors that tells the computer what mode the motor is in. They often wear out and don't reliably report the position back to the system. If you still have your original you could investigate this on the unit. Carefully remove that black plastic piece on the motor. There are 4 tabs that secure it. Inside you will see the sensor. I have done 3 of these in the last year.

The sensor can be found online. I bought mine from Amazon for about $60
 

Attachments

1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top