Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 6 of 6 Posts

·
Registered
2002 chevy trailblazer_ltz
Joined
·
8 Posts
Discussion Starter #1
My 2002 trailblazer has been switching itself into 4WD on its own. The first time I've noticed this happening was when I was taking a sharp right at a light into a gas station then took a sharp left up to a pump. It was hard to move taking the turn pulling in and then even harder pulling up to the pump, that's when I noticed there was something wrong with the 4WD selector switch. Multiple modes were lit up or blinking. I turned the switch to 2HI and my truck jerked around but then seemed fine after that. The same thing has happened a few times after that. I have noticed it at a high speed before but I'm not sure if it switched over while at high speeds or not. Each time it happens I stop, put it in neutral, move the switch out of the 2HI position then back into 2HI and then its fine again. Last time I drove it the "service 4WD" light came on.

I'm trying not to drive it right now unless I have to. I'm starting a new job soon and will have to drive then so I hope to fix it before then. I'm going to be doing all the work myself. I was thinking I'll start with replacing the selector switch then swapping out the transfer case control module. Before I do anything I figured it would be a good idea to post this thread first to see if anyone else had a better idea of what could be causing this problem. I'm also very low on cash and can't afford to put a lot of money into it without fixing the problem. Once I find the solution I plan to report back to this thread.

If anyone has had this problem before, I would appreciate some advice. Thank you.
 

·
Registered
2004 gmc envoy_slt
Joined
·
2,503 Posts
The 2002's had a problem with the TCCM going stupid sometimes. If you replace it, get one from a 2003+ truck.

Before changing anything, try rotating the 4WD selector switch thru all of it's positions multiple times while truck is off. The contacts sometimes get dirty.
 

·
Registered
2002 chevy trailblazer_ltz
Joined
·
8 Posts
Discussion Starter #3
got tccm

I'm going to be putting in a TCCM tomorrow. I believe was out of a 2007 trailblazer. The part number is 24233673. Really hoping this works.
 

·
Registered
2002 chevy trailblazer_ltz
Joined
·
8 Posts
Discussion Starter #4 (Edited)
the new TCCM seemed to work fine with no problems for a couple weeks but now the light on the switch blinks on startup then goes out completely and a red N is lit up on switch. sames thing happens trying to switch modes too, just blinks then goes out.
 

·
Registered
2002 chevy trailblazer_ltz
Joined
·
8 Posts
Discussion Starter #5 (Edited)
still not fixed

I tried removing and reconnecting the tccm and selector switch and making sure the connections were good but nothing changed. I also tried switching back to the old tccm just to see if the if the old problem came back but it's doing the same thing using both tccms now. I don't hear it trying to engage at all with this problem so i guess I'll probably try replacing the encoder motor next.
 

·
Registered
2002 chevy trailblazer_ltz
Joined
·
8 Posts
Discussion Starter #6 (Edited)
I'm still at a loss. I'm still thinking about replacing the encoder motor but don't want to spend the money for it not to work and I don't think I'm supposed to do it while its still in 4WD.
 
1 - 6 of 6 Posts
Top