Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 3 of 3 Posts

·
Registered
2002 gmc envoy_slt
Joined
·
28 Posts
Discussion Starter #1
So. This has been an issue for my envoy for quite some time. It first started when I would make hard U turns, the 4 wheel drive would engauge and it would be very diffficult to turn. It happens often enough to make it a nusiance. Now, while driving it will engauge out of no where. The switch says 2WD and the light is indicating 4HI. Yesterday this happened and the service 4wd light came on. I am wondering if anyone else has this problem and if there is an easy fix. It does not seem to do any harm, and im not sure if it is actually engauging when driving fast. However, it does worry me becuase if it did engauge and we were going around a sharp corner fast, it could possibly break something or someone :( . I do know of a GMC Sierra that has done the same thing in the past.

Thanks for your thoughts.
 

·
Banned
2004 gmc
Joined
·
26,181 Posts
Surely a bad thing that can damage components or cause a loss of control on corners. 2002 were notorious for having bad TCCMs, but the failure mode was a failure to initialize upon ignition start, not a failure to accurately read the switch position.

Recommend you change the switch first, since it's cheap nowadays, even from the dealer, after a 2005-2006 redesign for better reliability.

Also, how many miles do you have, and (since I always ask, even if it's not specifically related to the problem at hand) have you changed the transfer case fluid as required every 50K miles?
 

·
Registered
2002 gmc envoy_slt
Joined
·
28 Posts
Discussion Starter #3
It has 150,000 on it now. I got it when it was at 120 or so. I figure I should change the fluid since im not sure if it was ever done previously. Is it hard to do? im not 100% mechanically inclined, but with this envoy I am learning some ins and outs. Also, have you heard of the new switch fixing the problem completely?
 
1 - 3 of 3 Posts
Top